{"answers":{"affected":"3 open source packages ship an affected version, including uwsgi and uWSGI. It affects 2 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2018-7490 exists.","fix":"Upgrade uwsgi to 2.0.17 or later.","what":"CVE-2018-7490 is a high-severity path traversal vulnerability in Debian Debian Linux, published on 26 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-7490 and fix it if it is affected.\n\nWhat it is: CVE-2018-7490 is a high-severity path traversal vulnerability in Debian Debian Linux, published on 26 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2018-7490 exists.\n\nAffected packages and fixed versions:\n- uwsgi (PyPI): affected all versions; fixed in 2.0.17\n- uwsgi (PyPI): affected all versions; fixed in 2.0.17\n- uWSGI (PyPI): affected all versions; fixed in 2.0.17\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-7490/ (Markdown: https://insights.sbomify.com/CVE-2018-7490/index.md)","id":"CVE-2018-7490","markdown":"https://insights.sbomify.com/CVE-2018-7490/index.md","name":"CVE-2018-7490","record":{"aliases":["ALPINE-CVE-2018-7490","DEBIAN-CVE-2018-7490","DSA-4142-1","GHSA-h2vm-c85r-5vh5","PYSEC-2018-78","UBUNTU-CVE-2018-7490"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"uWSGI application server","requires_auth":"none","summary":"Attackers can traverse directories to read arbitrary files when the --php-docroot option is enabled in uWSGI.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"uwsgi","vendor":"unbit"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"uWSGI before 2.0.17 mishandles a DOCUMENT_ROOT check during use of the --php-docroot option, allowing directory traversal.","ecosystems":["PyPI"],"exploits":{"exploitdb":1,"first_seen":"2018-03-02","github_poc":2,"max_poc_stars":1,"metasploit":0,"nuclei":1,"refs":[{"date":"2024-06-14T02:50:35Z","kind":"github_poc","ref":"https://github.com/qinzhu111/uWSGI-CVE-2018-7490-POC","stars":1,"title":null},{"date":"2018-03-02","kind":"exploitdb","ref":"44223","stars":null,"title":"uWSGI \u003c 2.0.17 - Directory Traversal"},{"date":"2026-10-08T19:51:33Z","kind":"github_poc","ref":"https://github.com/CyberCTF/vulhub-uwsgi-cve-2018-7490","stars":0,"title":"Vulhub uwsgi/CVE-2018-7490: uWSGI PHP Plugin Path Traversal (CVE-2018-7490), run with Isoloom"},{"date":null,"kind":"nuclei","ref":"http/cves/2018/CVE-2018-7490.yaml","stars":null,"title":"uWSGI PHP Plugin Local File Inclusion"}],"tier":"weaponised"},"has_fix":true,"headline":"uWSGI Directory Traversal vulnerability","id":"CVE-2018-7490","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"debian:debian_linux","products":["debian:debian_linux"],"type":"path_traversal","year":"2018"},"n_packages":3,"n_references":3,"next":{"headline":"Other in n/a","id":"CVE-2018-7491"},"packages":[{"ecosystem":"PyPI","fixed":["2.0.17"],"introduced":["0"],"last_affected":[],"package":"uWSGI","purl":null,"source":"GHSA-h2vm-c85r-5vh5"},{"ecosystem":"PyPI","fixed":["2.0.17"],"introduced":["0"],"last_affected":[],"package":"uwsgi","purl":"pkg:pypi/uwsgi","source":"GHSA-h2vm-c85r-5vh5"},{"ecosystem":"PyPI","fixed":["2.0.17"],"introduced":["0"],"last_affected":[],"package":"uwsgi","purl":"pkg:pypi/uwsgi","source":"PYSEC-2018-78"}],"prev":{"headline":"FasterXML jackson-databind allows unauthenticated remote code execution","id":"CVE-2018-7489"},"products":["n/a"],"published":"2018-02-26","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can traverse directories to read arbitrary files when the --php-docroot option is enabled in uWSGI.","url":"https://insights.sbomify.com/CVE-2018-7490/"}