# CVE-2018-7490: uWSGI Directory Traversal vulnerability

> Attackers can traverse directories to read arbitrary files when the --php-docroot option is enabled in uWSGI.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Feb 2018
- **Updated:** 5 Aug 2024
- **Also known as:** ALPINE-CVE-2018-7490, DEBIAN-CVE-2018-7490, DSA-4142-1, GHSA-h2vm-c85r-5vh5, PYSEC-2018-78, UBUNTU-CVE-2018-7490

## What is CVE-2018-7490?

CVE-2018-7490 is a high-severity path traversal vulnerability in Debian Debian Linux, published on 26 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

uWSGI before 2.0.17 mishandles a DOCUMENT_ROOT check during use of the --php-docroot option, allowing directory traversal.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2018-7490?

3 open source packages ship an affected version, including uwsgi and uWSGI. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `uwsgi` | PyPI | All versions | 2.0.17 |
| `uwsgi` | PyPI | All versions | 2.0.17 |
| `uWSGI` | PyPI | All versions | 2.0.17 |

Products: Debian Debian Linux, Unbit Uwsgi.

## How do I fix CVE-2018-7490?

Upgrade uwsgi to 2.0.17 or later.

## Is CVE-2018-7490 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2018-7490 exists.

Public exploit code:

- https://github.com/qinzhu111/uWSGI-CVE-2018-7490-POC (github_poc): https://github.com/qinzhu111/uWSGI-CVE-2018-7490-POC
- uWSGI < 2.0.17 - Directory Traversal (exploitdb)
- Vulhub uwsgi/CVE-2018-7490: uWSGI PHP Plugin Path Traversal (CVE-2018-7490), run with Isoloom (github_poc): https://github.com/CyberCTF/vulhub-uwsgi-cve-2018-7490
- uWSGI PHP Plugin Local File Inclusion (nuclei): http/cves/2018/CVE-2018-7490.yaml

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-7490 and fix it if it is affected.

What it is: CVE-2018-7490 is a high-severity path traversal vulnerability in Debian Debian Linux, published on 26 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2018-7490 exists.

Affected packages and fixed versions:
- uwsgi (PyPI): affected all versions; fixed in 2.0.17
- uwsgi (PyPI): affected all versions; fixed in 2.0.17
- uWSGI (PyPI): affected all versions; fixed in 2.0.17

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-7490/ (Markdown: https://insights.sbomify.com/CVE-2018-7490/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-7490
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-7490
- OSV: https://osv.dev/vulnerability/CVE-2018-7490

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-7490/
Summaries are generated and may contain mistakes; the official description above is the record.
