{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-7544 in the wild and no public exploit code.","fix":"Change a configuration setting.","what":"CVE-2018-7544 is a critical vulnerability in n/a, published on 16 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-7544 and fix it if it is affected.\n\nWhat it is: CVE-2018-7544 is a critical vulnerability in n/a, published on 16 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-7544 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-7544/ (Markdown: https://insights.sbomify.com/CVE-2018-7544/index.md)","id":"CVE-2018-7544","markdown":"https://insights.sbomify.com/CVE-2018-7544/index.md","name":"CVE-2018-7544","record":{"aliases":["GHSA-9vqg-v7fx-9jvr","UBUNTU-CVE-2018-7544","openSUSE-SU-2024:11692-1"],"analysis":{"component_type":"server_software","fix_type":"configuration_change","impacts":["code_execution","denial_of_service","data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"OpenVPN management interface","requires_auth":"none","summary":"Attackers can execute arbitrary commands or cause DoS via CSRF if the OpenVPN management interface is enabled over TCP without authentication.","user_interaction":"not_required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"openvpn","vendor":"openvpn"}],"cvss":{"score":9.1,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-134","name":"Use of Externally-Controlled Format String"}],"description":"A cross-protocol scripting issue was discovered in the management interface in OpenVPN through 2.4.5. When this interface is enabled over TCP without a password, and when no other clients are connected to this interface, attackers can execute arbitrary management commands, obtain sensitive information, or cause a denial of service (SIGTERM) by triggering XMLHttpRequest actions in a web browser. This is demonstrated by a multipart/form-data POST to http://localhost:23000 with a \"signal SIGTERM\" command in a TEXTAREA element. NOTE: The vendor disputes that this is a vulnerability. They state that this is the result of improper configuration of the OpenVPN instance rather than an intrinsic vulnerability, and now more explicitly warn against such configurations in both the management-interface documentation, and with a runtime warning","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site request forgery in n/a","id":"CVE-2018-7544","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"csrf","year":"2018"},"n_packages":1,"n_references":1,"next":{"headline":"Denial of service in n/a","id":"CVE-2018-7546"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["2.5.4-2.1"],"introduced":["0"],"last_affected":[],"package":"openvpn","purl":"pkg:rpm/opensuse/openvpn\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:11692-1"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2018-7543"},"products":["n/a"],"published":"2018-03-16","related":[{"cvss_score":9.1,"headline":"Memory corruption in OpenVPN","id":"CVE-2025-12106","kev_date_added":null,"published":"2025-12-01"},{"cvss_score":9.1,"headline":"Information disclosure in OpenVPN","id":"CVE-2024-5594","kev_date_added":null,"published":"2025-01-06"},{"cvss_score":9,"headline":"Code injection in n/a","id":"CVE-2006-1629","kev_date_added":null,"published":"2006-04-06"},{"cvss_score":8.8,"headline":"Privilege escalation in OpenVPN","id":"CVE-2024-4877","kev_date_added":null,"published":"2025-04-03"},{"cvss_score":7.8,"headline":"Code injection in OpenVPN-GUI","id":"CVE-2021-3606","kev_date_added":null,"published":"2021-07-02"},{"cvss_score":7.8,"headline":"Use after free in n/a","id":"CVE-2018-9336","kev_date_added":null,"published":"2018-05-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-11-14","vendors":["n/a"]},"summary":"Attackers can execute arbitrary commands or cause DoS via CSRF if the OpenVPN management interface is enabled over TCP without authentication.","url":"https://insights.sbomify.com/CVE-2018-7544/"}