{"answers":{"affected":"2 open source packages ship an affected version, including aws-lambda-multipart-parser. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-7560 in the wild and no public exploit code.","fix":"Upgrade aws-lambda-multipart-parser to 0.1.2 or later.","what":"CVE-2018-7560 is a high-severity denial of service vulnerability in n/a, published on 4 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-7560 and fix it if it is affected.\n\nWhat it is: CVE-2018-7560 is a high-severity denial of service vulnerability in n/a, published on 4 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-7560 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- aws-lambda-multipart-parser (npm): affected all versions; fixed in 0.1.2\n- aws-lambda-multipart-parser (npm): affected all versions; fixed in 0.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-7560/ (Markdown: https://insights.sbomify.com/CVE-2018-7560/index.md)","id":"CVE-2018-7560","markdown":"https://insights.sbomify.com/CVE-2018-7560/index.md","name":"CVE-2018-7560","record":{"aliases":["GHSA-6jqp-j69q-pm62"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js multipart parser","requires_auth":"none","summary":"An attacker can cause a denial of service in applications using the aws-lambda-multipart-parser library by sending a crafted multipart boundary string.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"aws-lambda-multipart-parser","vendor":"aws-lambda-multipart-parser_project"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"index.js in the Anton Myshenin aws-lambda-multipart-parser NPM package before 0.1.2 has a Regular Expression Denial of Service (ReDoS) issue via a crafted multipart/form-data boundary string.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"AWS Lambda parser is vulnerable to Regular Expression Denial of Service","id":"CVE-2018-7560","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"Memory corruption in n/a","id":"CVE-2018-7561"},"packages":[{"ecosystem":"npm","fixed":["0.1.2"],"introduced":["0"],"last_affected":[],"package":"aws-lambda-multipart-parser","purl":null,"source":"GHSA-6jqp-j69q-pm62"},{"ecosystem":"npm","fixed":["0.1.2"],"introduced":["0"],"last_affected":[],"package":"aws-lambda-multipart-parser","purl":"pkg:npm/aws-lambda-multipart-parser","source":"GHSA-6jqp-j69q-pm62"}],"prev":{"headline":"OPC UA applications can allow a remote attacker to determine a Server's private key","id":"CVE-2018-7559"},"products":["n/a"],"published":"2018-03-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"An attacker can cause a denial of service in applications using the aws-lambda-multipart-parser library by sending a crafted multipart boundary string.","url":"https://insights.sbomify.com/CVE-2018-7560/"}