# CVE-2018-7560: AWS Lambda parser is vulnerable to Regular Expression Denial of Service

> An attacker can cause a denial of service in applications using the aws-lambda-multipart-parser library by sending a crafted multipart boundary string.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Mar 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-6jqp-j69q-pm62

## What is CVE-2018-7560?

CVE-2018-7560 is a high-severity denial of service vulnerability in n/a, published on 4 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

index.js in the Anton Myshenin aws-lambda-multipart-parser NPM package before 0.1.2 has a Regular Expression Denial of Service (ReDoS) issue via a crafted multipart/form-data boundary string.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2018-7560?

2 open source packages ship an affected version, including aws-lambda-multipart-parser. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aws-lambda-multipart-parser` | npm | All versions | 0.1.2 |
| `aws-lambda-multipart-parser` | npm | All versions | 0.1.2 |

Products: Aws-Lambda-Multipart-Parser Project Aws-Lambda-Multipart-Parser.

## How do I fix CVE-2018-7560?

Upgrade aws-lambda-multipart-parser to 0.1.2 or later.

## Is CVE-2018-7560 being exploited?

There is no known exploitation of CVE-2018-7560 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-7560 and fix it if it is affected.

What it is: CVE-2018-7560 is a high-severity denial of service vulnerability in n/a, published on 4 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-7560 in the wild and no public exploit code.

Affected packages and fixed versions:
- aws-lambda-multipart-parser (npm): affected all versions; fixed in 0.1.2
- aws-lambda-multipart-parser (npm): affected all versions; fixed in 0.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-7560/ (Markdown: https://insights.sbomify.com/CVE-2018-7560/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-7560
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-7560
- OSV: https://osv.dev/vulnerability/CVE-2018-7560

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-7560/
Summaries are generated and may contain mistakes; the official description above is the record.
