CVE-2018-7575 Integer Overflow or Wraparound in Google TensorFlow
An integer overflow in TensorFlow can lead to buffer overflows, potentially allowing code execution or denial of service.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2018-7575?
CVE-2018-7575 is a critical vulnerability in Google Tensorflow, published on 24 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Google TensorFlow 1.7.x and earlier is affected by a Buffer Overflow vulnerability. The type of exploitation is context-dependent.
Weakness: CWE-190
Which versions are affected by CVE-2018-7575?
7 open source packages ship an affected version, including tensorflow, tensorflow-cpu and tensorflow-gpu. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
tensorflow PyPI | All versions | 1.7.1 |
tensorflow PyPI | From 1.0.0 | 1.7.1 |
tensorflow PyPI | From 1.0.0 | 1.7.1 |
tensorflow-cpu PyPI | All versions | 1.7.1 |
tensorflow-gpu PyPI | All versions | 1.7.1 |
tensorflow-gpu PyPI | From 1.0.0 | 1.7.1 |
1 more packages
tensorflow-gpu PyPI | From 1.0.0 | 1.7.1 |
Products include Google Tensorflow.
How do I fix CVE-2018-7575?
Upgrade tensorflow to 1.7.1 or later.
Is CVE-2018-7575 being exploited?
There is no known exploitation of CVE-2018-7575 in the wild and no public exploit code.
Other vulnerabilities in Google Tensorflow
Sources
Also known as GHSA-mw6v-crh8-8533, PYSEC-2019-205, PYSEC-2019-223, PYSEC-2019-230.