{"answers":{"affected":"7 open source packages ship an affected version, including tensorflow, tensorflow-cpu and tensorflow-gpu. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-7575 in the wild and no public exploit code.","fix":"Upgrade tensorflow to 1.7.1 or later.","what":"CVE-2018-7575 is a critical vulnerability in Google Tensorflow, published on 24 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-7575 and fix it if it is affected.\n\nWhat it is: CVE-2018-7575 is a critical vulnerability in Google Tensorflow, published on 24 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-7575 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- tensorflow (PyPI): affected all versions; fixed in 1.7.1\n- tensorflow (PyPI): affected from 1.0.0; fixed in 1.7.1\n- tensorflow (PyPI): affected from 1.0.0; fixed in 1.7.1\n- tensorflow-cpu (PyPI): affected all versions; fixed in 1.7.1\n- tensorflow-gpu (PyPI): affected all versions; fixed in 1.7.1\n- tensorflow-gpu (PyPI): affected from 1.0.0; fixed in 1.7.1\n- tensorflow-gpu (PyPI): affected from 1.0.0; fixed in 1.7.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-7575/ (Markdown: https://insights.sbomify.com/CVE-2018-7575/index.md)","id":"CVE-2018-7575","markdown":"https://insights.sbomify.com/CVE-2018-7575/index.md","name":"CVE-2018-7575","record":{"aliases":["GHSA-mw6v-crh8-8533","PYSEC-2019-205","PYSEC-2019-223","PYSEC-2019-230"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"TensorFlow library","requires_auth":"none","summary":"An integer overflow in TensorFlow can lead to buffer overflows, potentially allowing code execution or denial of service.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"tensorflow","vendor":"google"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-190","name":"Integer Overflow or Wraparound"}],"description":"Google TensorFlow 1.7.x and earlier is affected by a Buffer Overflow vulnerability. The type of exploitation is context-dependent.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Integer Overflow or Wraparound in Google TensorFlow","id":"CVE-2018-7575","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"google:tensorflow","products":["google:tensorflow"],"type":"integer_overflow","year":"2018"},"n_packages":7,"n_references":1,"next":{"headline":"Null pointer dereference in TensorFlow leads to exploitation","id":"CVE-2018-7576"},"packages":[{"ecosystem":"PyPI","fixed":["1.7.1"],"introduced":["0"],"last_affected":[],"package":"tensorflow","purl":"pkg:pypi/tensorflow","source":"PYSEC-2019-205"},{"ecosystem":"PyPI","fixed":["1.7.1"],"introduced":["1.0.0"],"last_affected":[],"package":"tensorflow","purl":null,"source":"GHSA-mw6v-crh8-8533"},{"ecosystem":"PyPI","fixed":["1.7.1"],"introduced":["1.0.0"],"last_affected":[],"package":"tensorflow","purl":"pkg:pypi/tensorflow","source":"GHSA-mw6v-crh8-8533"},{"ecosystem":"PyPI","fixed":["1.7.1"],"introduced":["0"],"last_affected":[],"package":"tensorflow-cpu","purl":"pkg:pypi/tensorflow-cpu","source":"PYSEC-2019-223"},{"ecosystem":"PyPI","fixed":["1.7.1"],"introduced":["0"],"last_affected":[],"package":"tensorflow-gpu","purl":"pkg:pypi/tensorflow-gpu","source":"PYSEC-2019-230"},{"ecosystem":"PyPI","fixed":["1.7.1"],"introduced":["1.0.0"],"last_affected":[],"package":"tensorflow-gpu","purl":null,"source":"GHSA-mw6v-crh8-8533"},{"ecosystem":"PyPI","fixed":["1.7.1"],"introduced":["1.0.0"],"last_affected":[],"package":"tensorflow-gpu","purl":"pkg:pypi/tensorflow-gpu","source":"GHSA-mw6v-crh8-8533"}],"prev":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2018-7574"},"products":["n/a"],"published":"2019-04-24","related":[{"cvss_score":9.8,"headline":"TensorFlow vulnerable to heap out-of-buffer read in the QuantizeAndDequantize operation","id":"CVE-2023-25668","kev_date_added":null,"published":"2023-03-24"},{"cvss_score":9.3,"headline":"Arbitrary code execution due to YAML deserialization","id":"CVE-2021-37678","kev_date_added":null,"published":"2021-08-12"},{"cvss_score":9.1,"headline":"Path traversal in n/a","id":"CVE-2021-35958","kev_date_added":null,"published":"2021-06-30"},{"cvss_score":9,"headline":"Integer truncation in Shard API usage","id":"CVE-2020-15202","kev_date_added":null,"published":"2020-09-25"},{"cvss_score":9,"headline":"Data leak in Tensorflow","id":"CVE-2020-15205","kev_date_added":null,"published":"2020-09-25"},{"cvss_score":9,"headline":"Denial of Service in Tensorflow","id":"CVE-2020-15206","kev_date_added":null,"published":"2020-09-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"An integer overflow in TensorFlow can lead to buffer overflows, potentially allowing code execution or denial of service.","url":"https://insights.sbomify.com/CVE-2018-7575/"}