CVE-2018-7576 Null pointer dereference in TensorFlow leads to exploitation

Medium 6.5 Published Updated

A null pointer dereference in TensorFlow allows attackers to cause a denial of service via context-dependent exploitation.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2018-7576?

CVE-2018-7576 is a medium-severity vulnerability in Google Tensorflow, published on 23 Apr 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Google TensorFlow 1.6.x and earlier is affected by: Null Pointer Dereference. The type of exploitation is: context-dependent.

Weakness: CWE-476

Which versions are affected by CVE-2018-7576?

7 open source packages ship an affected version, including tensorflow, tensorflow-cpu and tensorflow-gpu. It affects 1 product.

PackageAffectedFixed in
tensorflow PyPIAll versions1.7.0rc0
tensorflow PyPIFrom 1.0.01.6.0
tensorflow PyPIFrom 1.0.01.6.0
tensorflow-cpu PyPIAll versions1.7.0rc0
tensorflow-gpu PyPIAll versions1.7.0rc0
tensorflow-gpu PyPIFrom 1.0.01.6.0
1 more packages
tensorflow-gpu PyPIFrom 1.0.01.6.0

Products include Google Tensorflow.

How do I fix CVE-2018-7576?

Upgrade tensorflow to a fixed version for your release line: 1.7.0rc0 or 1.6.0.

Is CVE-2018-7576 being exploited?

There is no known exploitation of CVE-2018-7576 in the wild and no public exploit code.

All Google Tensorflow vulnerabilities

Sources

Also known as GHSA-jfq2-rj7f-9gvf, PYSEC-2019-206, PYSEC-2019-224, PYSEC-2019-231.

Is CVE-2018-7576 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free