{"answers":{"affected":"7 open source packages ship an affected version, including tensorflow, tensorflow-cpu and tensorflow-gpu. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-7576 in the wild and no public exploit code.","fix":"Upgrade tensorflow to a fixed version for your release line: 1.7.0rc0 or 1.6.0.","what":"CVE-2018-7576 is a medium-severity vulnerability in Google Tensorflow, published on 23 Apr 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-7576 and fix it if it is affected.\n\nWhat it is: CVE-2018-7576 is a medium-severity vulnerability in Google Tensorflow, published on 23 Apr 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-7576 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- tensorflow (PyPI): affected all versions; fixed in 1.7.0rc0\n- tensorflow (PyPI): affected from 1.0.0; fixed in 1.6.0\n- tensorflow (PyPI): affected from 1.0.0; fixed in 1.6.0\n- tensorflow-cpu (PyPI): affected all versions; fixed in 1.7.0rc0\n- tensorflow-gpu (PyPI): affected all versions; fixed in 1.7.0rc0\n- tensorflow-gpu (PyPI): affected from 1.0.0; fixed in 1.6.0\n- tensorflow-gpu (PyPI): affected from 1.0.0; fixed in 1.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-7576/ (Markdown: https://insights.sbomify.com/CVE-2018-7576/index.md)","id":"CVE-2018-7576","markdown":"https://insights.sbomify.com/CVE-2018-7576/index.md","name":"CVE-2018-7576","record":{"aliases":["GHSA-jfq2-rj7f-9gvf","PYSEC-2019-206","PYSEC-2019-224","PYSEC-2019-231"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"TensorFlow machine learning library","requires_auth":"none","summary":"A null pointer dereference in TensorFlow allows attackers to cause a denial of service via context-dependent exploitation.","user_interaction":"required","vuln_class":"null_dereference"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"tensorflow","vendor":"google"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-476","name":"NULL Pointer Dereference"}],"description":"Google TensorFlow 1.6.x and earlier is affected by: Null Pointer Dereference. The type of exploitation is: context-dependent.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Null pointer dereference in TensorFlow leads to exploitation","id":"CVE-2018-7576","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"google:tensorflow","products":["google:tensorflow"],"type":"null_dereference","year":"2018"},"n_packages":7,"n_references":1,"next":{"headline":"Improper Input Validation in Google TensorFlow","id":"CVE-2018-7577"},"packages":[{"ecosystem":"PyPI","fixed":["1.7.0rc0"],"introduced":["0"],"last_affected":[],"package":"tensorflow","purl":"pkg:pypi/tensorflow","source":"PYSEC-2019-206"},{"ecosystem":"PyPI","fixed":["1.6.0"],"introduced":["1.0.0"],"last_affected":[],"package":"tensorflow","purl":null,"source":"GHSA-jfq2-rj7f-9gvf"},{"ecosystem":"PyPI","fixed":["1.6.0"],"introduced":["1.0.0"],"last_affected":[],"package":"tensorflow","purl":"pkg:pypi/tensorflow","source":"GHSA-jfq2-rj7f-9gvf"},{"ecosystem":"PyPI","fixed":["1.7.0rc0"],"introduced":["0"],"last_affected":[],"package":"tensorflow-cpu","purl":"pkg:pypi/tensorflow-cpu","source":"PYSEC-2019-224"},{"ecosystem":"PyPI","fixed":["1.7.0rc0"],"introduced":["0"],"last_affected":[],"package":"tensorflow-gpu","purl":"pkg:pypi/tensorflow-gpu","source":"PYSEC-2019-231"},{"ecosystem":"PyPI","fixed":["1.6.0"],"introduced":["1.0.0"],"last_affected":[],"package":"tensorflow-gpu","purl":null,"source":"GHSA-jfq2-rj7f-9gvf"},{"ecosystem":"PyPI","fixed":["1.6.0"],"introduced":["1.0.0"],"last_affected":[],"package":"tensorflow-gpu","purl":"pkg:pypi/tensorflow-gpu","source":"GHSA-jfq2-rj7f-9gvf"}],"prev":{"headline":"Integer Overflow or Wraparound in Google TensorFlow","id":"CVE-2018-7575"},"products":["n/a"],"published":"2019-04-23","related":[{"cvss_score":9.8,"headline":"TensorFlow vulnerable to heap out-of-buffer read in the QuantizeAndDequantize operation","id":"CVE-2023-25668","kev_date_added":null,"published":"2023-03-24"},{"cvss_score":9.8,"headline":"Integer Overflow or Wraparound in Google TensorFlow","id":"CVE-2018-7575","kev_date_added":null,"published":"2019-04-24"},{"cvss_score":9.3,"headline":"Arbitrary code execution due to YAML deserialization","id":"CVE-2021-37678","kev_date_added":null,"published":"2021-08-12"},{"cvss_score":9.1,"headline":"Path traversal in n/a","id":"CVE-2021-35958","kev_date_added":null,"published":"2021-06-30"},{"cvss_score":9,"headline":"Integer truncation in Shard API usage","id":"CVE-2020-15202","kev_date_added":null,"published":"2020-09-25"},{"cvss_score":9,"headline":"Data leak in Tensorflow","id":"CVE-2020-15205","kev_date_added":null,"published":"2020-09-25"},{"cvss_score":9,"headline":"Denial of Service in Tensorflow","id":"CVE-2020-15206","kev_date_added":null,"published":"2020-09-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"A null pointer dereference in TensorFlow allows attackers to cause a denial of service via context-dependent exploitation.","url":"https://insights.sbomify.com/CVE-2018-7576/"}