# CVE-2018-7576: Null pointer dereference in TensorFlow leads to exploitation

> A null pointer dereference in TensorFlow allows attackers to cause a denial of service via context-dependent exploitation.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Apr 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-jfq2-rj7f-9gvf, PYSEC-2019-206, PYSEC-2019-224, PYSEC-2019-231

## What is CVE-2018-7576?

CVE-2018-7576 is a medium-severity vulnerability in Google Tensorflow, published on 23 Apr 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Google TensorFlow 1.6.x and earlier is affected by: Null Pointer Dereference. The type of exploitation is: context-dependent.

Weakness: CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2018-7576?

7 open source packages ship an affected version, including tensorflow, tensorflow-cpu and tensorflow-gpu. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tensorflow` | PyPI | All versions | 1.7.0rc0 |
| `tensorflow` | PyPI | From 1.0.0 | 1.6.0 |
| `tensorflow` | PyPI | From 1.0.0 | 1.6.0 |
| `tensorflow-cpu` | PyPI | All versions | 1.7.0rc0 |
| `tensorflow-gpu` | PyPI | All versions | 1.7.0rc0 |
| `tensorflow-gpu` | PyPI | From 1.0.0 | 1.6.0 |
| `tensorflow-gpu` | PyPI | From 1.0.0 | 1.6.0 |

Products: Google Tensorflow.

## How do I fix CVE-2018-7576?

Upgrade tensorflow to a fixed version for your release line: 1.7.0rc0 or 1.6.0.

## Is CVE-2018-7576 being exploited?

There is no known exploitation of CVE-2018-7576 in the wild and no public exploit code.

## Other vulnerabilities in Google Tensorflow

- [CVE-2023-25668](https://insights.sbomify.com/CVE-2023-25668/): TensorFlow vulnerable to heap out-of-buffer read in the QuantizeAndDequantize operation (critical 9.8)
- [CVE-2018-7575](https://insights.sbomify.com/CVE-2018-7575/): Integer Overflow or Wraparound in Google TensorFlow (critical 9.8)
- [CVE-2021-37678](https://insights.sbomify.com/CVE-2021-37678/): Arbitrary code execution due to YAML deserialization (critical 9.3)
- [CVE-2021-35958](https://insights.sbomify.com/CVE-2021-35958/): Path traversal in n/a (critical 9.1)
- [CVE-2020-15202](https://insights.sbomify.com/CVE-2020-15202/): Integer truncation in Shard API usage (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-7576 and fix it if it is affected.

What it is: CVE-2018-7576 is a medium-severity vulnerability in Google Tensorflow, published on 23 Apr 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-7576 in the wild and no public exploit code.

Affected packages and fixed versions:
- tensorflow (PyPI): affected all versions; fixed in 1.7.0rc0
- tensorflow (PyPI): affected from 1.0.0; fixed in 1.6.0
- tensorflow (PyPI): affected from 1.0.0; fixed in 1.6.0
- tensorflow-cpu (PyPI): affected all versions; fixed in 1.7.0rc0
- tensorflow-gpu (PyPI): affected all versions; fixed in 1.7.0rc0
- tensorflow-gpu (PyPI): affected from 1.0.0; fixed in 1.6.0
- tensorflow-gpu (PyPI): affected from 1.0.0; fixed in 1.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-7576/ (Markdown: https://insights.sbomify.com/CVE-2018-7576/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-7576
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-7576
- OSV: https://osv.dev/vulnerability/CVE-2018-7576

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-7576/
Summaries are generated and may contain mistakes; the official description above is the record.
