{"answers":{"affected":"It affects 3 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2018-7584 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2018-7584 is a critical memory corruption vulnerability in Canonical Ubuntu Linux, published on 1 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-7584 and fix it if it is affected.\n\nWhat it is: CVE-2018-7584 is a critical memory corruption vulnerability in Canonical Ubuntu Linux, published on 1 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2018-7584 exists.\n\nAffected product: Canonical Ubuntu Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-7584/ (Markdown: https://insights.sbomify.com/CVE-2018-7584/index.md)","id":"CVE-2018-7584","markdown":"https://insights.sbomify.com/CVE-2018-7584/index.md","name":"CVE-2018-7584","record":{"aliases":["ALPINE-CVE-2018-7584","DLA-1326-1","GHSA-w5h8-6928-2j67","MGASA-2018-0167","SUSE-SU-2018:0646-1","SUSE-SU-2018:0717-1","UBUNTU-CVE-2018-7584"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP core","requires_auth":"none","summary":"A stack-based buffer under-read in PHP's HTTP response parsing allows attackers to cause denial of service or potentially execute arbitrary code.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ubuntu_linux","vendor":"canonical"},{"product":"debian_linux","vendor":"debian"},{"product":"php","vendor":"php"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"In PHP through 5.6.33, 7.0.x before 7.0.28, 7.1.x through 7.1.14, and 7.2.x through 7.2.2, there is a stack-based buffer under-read while parsing an HTTP response in the php_stream_url_wrap_http_ex function in ext/standard/http_fopen_wrapper.c. This subsequently results in copying a large string.","ecosystems":["SUSE:Linux Enterprise Module for Web and Scripting 12","SUSE:Linux Enterprise Software Development Kit 12 SP2","SUSE:Linux Enterprise Software Development Kit 12 SP3"],"exploits":{"exploitdb":1,"first_seen":"2018-06-06","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2018-06-06","kind":"exploitdb","ref":"44846","stars":null,"title":"PHP 7.2.2 - 'php_stream_url_wrap_http_ex' Buffer Overflow"}],"tier":"weaponised"},"has_fix":true,"headline":"Memory corruption in n/a","id":"CVE-2018-7584","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux","debian:debian_linux","php:php"],"type":"memory_corruption","year":"2018"},"n_packages":6,"n_references":14,"next":{"headline":"Path traversal in n/a","id":"CVE-2018-7586"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for Web and Scripting 12","fixed":["5.5.14-109.24.1"],"introduced":["0"],"last_affected":[],"package":"php5","purl":"pkg:rpm/suse/php5\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Web%20and%20Scripting%2012","source":"SUSE-SU-2018:0717-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Web and Scripting 12","fixed":["7.0.7-50.32.1"],"introduced":["0"],"last_affected":[],"package":"php7","purl":"pkg:rpm/suse/php7\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Web%20and%20Scripting%2012","source":"SUSE-SU-2018:0646-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP2","fixed":["5.5.14-109.24.1"],"introduced":["0"],"last_affected":[],"package":"php5","purl":"pkg:rpm/suse/php5\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP2","source":"SUSE-SU-2018:0717-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP2","fixed":["7.0.7-50.32.1"],"introduced":["0"],"last_affected":[],"package":"php7","purl":"pkg:rpm/suse/php7\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP2","source":"SUSE-SU-2018:0646-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP3","fixed":["5.5.14-109.24.1"],"introduced":["0"],"last_affected":[],"package":"php5","purl":"pkg:rpm/suse/php5\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP3","source":"SUSE-SU-2018:0717-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP3","fixed":["7.0.7-50.32.1"],"introduced":["0"],"last_affected":[],"package":"php7","purl":"pkg:rpm/suse/php7\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP3","source":"SUSE-SU-2018:0646-1"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2018-7583"},"products":["n/a"],"published":"2018-03-01","related":[{"cvss_score":9.8,"headline":"SaltStack Salt Authentication Bypass","id":"CVE-2020-11651","kev_date_added":"2021-11-03","published":"2020-04-30"},{"cvss_score":9.8,"headline":"OpenSMTPD Remote Code Execution","id":"CVE-2020-7247","kev_date_added":"2022-03-25","published":"2020-01-29"},{"cvss_score":9.8,"headline":"Exim Out-of-bounds Write","id":"CVE-2019-16928","kev_date_added":"2022-03-03","published":"2019-09-27"},{"cvss_score":9.8,"headline":"Exim Buffer Overflow","id":"CVE-2018-6789","kev_date_added":"2021-11-03","published":"2018-02-08"},{"cvss_score":9.8,"headline":"Oracle Java SE and Java SE Embedded Remote Code Execution","id":"CVE-2015-2590","kev_date_added":"2022-03-03","published":"2015-07-16"},{"cvss_score":9.8,"headline":"Oracle JRE Remote Code Execution","id":"CVE-2013-0422","kev_date_added":"2022-05-25","published":"2013-01-10"},{"cvss_score":9.8,"headline":"Oracle Java SE Runtime Environment (JRE) Arbitrary Code Execution","id":"CVE-2011-3544","kev_date_added":"2022-03-03","published":"2011-10-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"A stack-based buffer under-read in PHP's HTTP response parsing allows attackers to cause denial of service or potentially execute arbitrary code.","url":"https://insights.sbomify.com/CVE-2018-7584/"}