CVE-2018-7600 Drupal Core Remote Code Execution
Remote attackers can execute arbitrary code on Drupal installations due to improper input validation in multiple subsystems.
- Exploited in the wild
- Since 3 Nov 2021
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2018-7600?
CVE-2018-7600 is a critical code injection vulnerability in Debian Debian Linux, published on 29 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6, and 8.5.x before 8.5.1 allows remote attackers to execute arbitrary code because of an issue affecting multiple subsystems with default or common module configurations.
Weakness: CWE-20
Which versions are affected by CVE-2018-7600?
17 open source packages ship an affected version, including drupal/core and drupal/drupal. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
drupal/core Packagist | From 7.0 | 7.58 |
drupal/core Packagist | From 7.0 | 7.58 |
drupal/core Packagist | From 8.0 | 8.3.9 |
drupal/core Packagist | From 8.0 | 8.3.9 |
drupal/core Packagist | From 8.0.0 | 8.3.9, 8.4.6, 8.5.1 |
drupal/core Packagist | From 8.4.0 | 8.4.6 |
11 more packages
drupal/core Packagist | From 8.4.0 | 8.4.6 |
drupal/core Packagist | From 8.5.0 | 8.5.1 |
drupal/core Packagist | From 8.5.0 | 8.5.1 |
drupal/drupal Packagist | From 7.0 | 7.58 |
drupal/drupal Packagist | From 7.0 | 7.58 |
drupal/drupal Packagist | From 8.0 | 8.3.9 |
drupal/drupal Packagist | From 8.0 | 8.3.9 |
drupal/drupal Packagist | From 8.4 | 8.4.6 |
drupal/drupal Packagist | From 8.4 | 8.4.6 |
drupal/drupal Packagist | From 8.5 | 8.5.1 |
drupal/drupal Packagist | From 8.5 | 8.5.1 |
Products include Debian Debian Linux, Drupal Drupal.
How do I fix CVE-2018-7600?
Upgrade drupal/core to a fixed version for your release line: 7.58, 8.3.9, 8.4.6 or 8.5.1. US federal agencies must fix it by 3 May 2022.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2018-7600 being exploited?
Yes. Attackers have exploited CVE-2018-7600 in the wild since at least 3 Nov 2021, including in ransomware campaigns.
Public exploit code: 1 Metasploit module, 4 Exploit-DB entries, 1 Nuclei template and 56 proofs of concept on GitHub.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as CLEANSTART-2024-RD27757, DLA-1325-1, DRUPAL-CORE-2018-002, DSA-4156-1, GHSA-7fh9-933g-885p, UBUNTU-CVE-2018-7600.