# CVE-2018-7600: Drupal Core Remote Code Execution

> Remote attackers can execute arbitrary code on Drupal installations due to improper input validation in multiple subsystems.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Yes, since 3 Nov 2021 (CISA KEV), used in ransomware
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Mar 2018
- **Updated:** 21 Oct 2025
- **Also known as:** CLEANSTART-2024-RD27757, DLA-1325-1, DRUPAL-CORE-2018-002, DSA-4156-1, GHSA-7fh9-933g-885p, UBUNTU-CVE-2018-7600

## What is CVE-2018-7600?

CVE-2018-7600 is a critical code injection vulnerability in Debian Debian Linux, published on 29 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6, and 8.5.x before 8.5.1 allows remote attackers to execute arbitrary code because of an issue affecting multiple subsystems with default or common module configurations.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2018-7600?

17 open source packages ship an affected version, including drupal/core and drupal/drupal. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `drupal/core` | Packagist | From 7.0 | 7.58 |
| `drupal/core` | Packagist | From 7.0 | 7.58 |
| `drupal/core` | Packagist | From 8.0 | 8.3.9 |
| `drupal/core` | Packagist | From 8.0 | 8.3.9 |
| `drupal/core` | Packagist | From 8.0.0 | 8.3.9, 8.4.6, 8.5.1 |
| `drupal/core` | Packagist | From 8.4.0 | 8.4.6 |
| `drupal/core` | Packagist | From 8.4.0 | 8.4.6 |
| `drupal/core` | Packagist | From 8.5.0 | 8.5.1 |
| `drupal/core` | Packagist | From 8.5.0 | 8.5.1 |
| `drupal/drupal` | Packagist | From 7.0 | 7.58 |
| `drupal/drupal` | Packagist | From 7.0 | 7.58 |
| `drupal/drupal` | Packagist | From 8.0 | 8.3.9 |
| `drupal/drupal` | Packagist | From 8.0 | 8.3.9 |
| `drupal/drupal` | Packagist | From 8.4 | 8.4.6 |
| `drupal/drupal` | Packagist | From 8.4 | 8.4.6 |
| `drupal/drupal` | Packagist | From 8.5 | 8.5.1 |
| `drupal/drupal` | Packagist | From 8.5 | 8.5.1 |

Products: Debian Debian Linux, Drupal Drupal.

## How do I fix CVE-2018-7600?

Upgrade drupal/core to a fixed version for your release line: 7.58, 8.3.9, 8.4.6 or 8.5.1. US federal agencies must fix it by 3 May 2022.

## Is CVE-2018-7600 being exploited?

Yes. Attackers have exploited CVE-2018-7600 in the wild since at least 3 Nov 2021, including in ransomware campaigns.

Public exploit code:

- Exploit for Drupal v7.x + v8.x (Drupalgeddon 2 / CVE-2018-7600 / SA-CORE-2018-002) (github_poc): https://github.com/dreadlocked/Drupalgeddon2
- 💀Proof-of-Concept for CVE-2018-7600 Drupal SA-CORE-2018-002 (github_poc): https://github.com/a2u/CVE-2018-7600
- Exploit for Drupal 7 <= 7.57 CVE-2018-7600 (github_poc): https://github.com/pimps/CVE-2018-7600
- CVE-2018-7600 Drupal RCE (github_poc): https://github.com/g0rx/CVE-2018-7600-Drupal-RCE
- CVE-2018-7600 - Drupal 7.x RCE (github_poc): https://github.com/firefart/CVE-2018-7600
- Exploit for CVE-2018-7600.. called drupalgeddon2,   (github_poc): https://github.com/lorddemon/drupalgeddon2

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-7600 and fix it if it is affected.

What it is: CVE-2018-7600 is a critical code injection vulnerability in Debian Debian Linux, published on 29 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2018-7600 in the wild since at least 3 Nov 2021, including in ransomware campaigns.

Affected packages and fixed versions:
- drupal/core (Packagist): affected from 7.0; fixed in 7.58
- drupal/core (Packagist): affected from 7.0; fixed in 7.58
- drupal/core (Packagist): affected from 8.0; fixed in 8.3.9
- drupal/core (Packagist): affected from 8.0; fixed in 8.3.9
- drupal/core (Packagist): affected from 8.0.0; fixed in 8.3.9, 8.4.6, 8.5.1
- drupal/core (Packagist): affected from 8.4.0; fixed in 8.4.6
- drupal/core (Packagist): affected from 8.4.0; fixed in 8.4.6
- drupal/core (Packagist): affected from 8.5.0; fixed in 8.5.1
- drupal/core (Packagist): affected from 8.5.0; fixed in 8.5.1
- drupal/drupal (Packagist): affected from 7.0; fixed in 7.58
- drupal/drupal (Packagist): affected from 7.0; fixed in 7.58
- drupal/drupal (Packagist): affected from 8.0; fixed in 8.3.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-7600/ (Markdown: https://insights.sbomify.com/CVE-2018-7600/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-7600
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-7600
- OSV: https://osv.dev/vulnerability/CVE-2018-7600

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-7600/
Summaries are generated and may contain mistakes; the official description above is the record.
