{"answers":{"affected":"6 open source packages ship an affected version, including simplesamlphp/saml2. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-7644 in the wild and no public exploit code.","fix":"Upgrade simplesamlphp/saml2 to a fixed version for your release line: 1.10.5, 2.3.7 or 3.1.3.","what":"CVE-2018-7644 is a high-severity authentication bypass vulnerability in n/a, published on 5 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-7644 and fix it if it is affected.\n\nWhat it is: CVE-2018-7644 is a high-severity authentication bypass vulnerability in n/a, published on 5 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-7644 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- simplesamlphp/saml2 (Packagist): affected all versions; fixed in 1.10.5\n- simplesamlphp/saml2 (Packagist): affected all versions; fixed in 1.10.5\n- simplesamlphp/saml2 (Packagist): affected from 2.0; fixed in 2.3.7\n- simplesamlphp/saml2 (Packagist): affected from 2.0; fixed in 2.3.7\n- simplesamlphp/saml2 (Packagist): affected from 3.0; fixed in 3.1.3\n- simplesamlphp/saml2 (Packagist): affected from 3.0; fixed in 3.1.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-7644/ (Markdown: https://insights.sbomify.com/CVE-2018-7644/index.md)","id":"CVE-2018-7644","markdown":"https://insights.sbomify.com/CVE-2018-7644/index.md","name":"CVE-2018-7644","record":{"aliases":["DEBIAN-CVE-2018-7644","GHSA-923w-2xv2-7pr8","UBUNTU-CVE-2018-7644"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"SAML authentication library","requires_auth":"none","summary":"Attackers can bypass SAML signature verification to impersonate users, requiring an upgrade of the SimpleSAMLphp library.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"simplesamlphp","vendor":"simplesamlphp"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-347","name":"Improper Verification of Cryptographic Signature"}],"description":"The XmlSecLibs library as used in the saml2 library in SimpleSAMLphp before 1.15.3 incorrectly verifies signatures on SAML assertions, allowing a remote attacker to construct a crafted SAML assertion on behalf of an Identity Provider that would pass as cryptographically valid, thereby allowing them to impersonate a user from that Identity Provider, aka a key confusion issue.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"SimpleSAMLphp Improper Verification of Cryptographic Signature","id":"CVE-2018-7644","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"auth_bypass","year":"2018"},"n_packages":6,"n_references":1,"next":{"headline":"Memory corruption in n/a","id":"CVE-2018-7648"},"packages":[{"ecosystem":"Packagist","fixed":["1.10.5"],"introduced":["0"],"last_affected":[],"package":"simplesamlphp/saml2","purl":null,"source":"GHSA-923w-2xv2-7pr8"},{"ecosystem":"Packagist","fixed":["1.10.5"],"introduced":["0"],"last_affected":[],"package":"simplesamlphp/saml2","purl":"pkg:composer/simplesamlphp/saml2","source":"GHSA-923w-2xv2-7pr8"},{"ecosystem":"Packagist","fixed":["2.3.7"],"introduced":["2.0"],"last_affected":[],"package":"simplesamlphp/saml2","purl":null,"source":"GHSA-923w-2xv2-7pr8"},{"ecosystem":"Packagist","fixed":["2.3.7"],"introduced":["2.0"],"last_affected":[],"package":"simplesamlphp/saml2","purl":"pkg:composer/simplesamlphp/saml2","source":"GHSA-923w-2xv2-7pr8"},{"ecosystem":"Packagist","fixed":["3.1.3"],"introduced":["3.0"],"last_affected":[],"package":"simplesamlphp/saml2","purl":null,"source":"GHSA-923w-2xv2-7pr8"},{"ecosystem":"Packagist","fixed":["3.1.3"],"introduced":["3.0"],"last_affected":[],"package":"simplesamlphp/saml2","purl":"pkg:composer/simplesamlphp/saml2","source":"GHSA-923w-2xv2-7pr8"}],"prev":{"headline":"Integer overflow in n/a","id":"CVE-2018-7643"},"products":["n/a"],"published":"2018-03-05","related":[{"cvss_score":9.8,"headline":"SimpleSAMLphp Session fixation issue and authentication bypass in the authcrypt module","id":"CVE-2017-12868","kev_date_added":null,"published":"2017-09-01"},{"cvss_score":7.1,"headline":"SimpleSAMLphp SP accepts a response from an unexpected IdP when unsigned `Response/InResponseTo` is combined with a signed assertion lacking `SubjectConfirmationData/InResponseTo`","id":"CVE-2026-49284","kev_date_added":null,"published":"2026-07-17"},{"cvss_score":6.1,"headline":"SimpleSAMLphp Open redirection protection bypass","id":"CVE-2018-6520","kev_date_added":null,"published":"2018-02-02"},{"cvss_score":5.9,"headline":"SimpleSAMLphp Unauthenticated encryption in CBC mode","id":"CVE-2017-12870","kev_date_added":null,"published":"2017-09-01"},{"cvss_score":5.9,"headline":"SimpleSAMLphp Incorrect IV generation for encryption","id":"CVE-2017-12871","kev_date_added":null,"published":"2017-09-01"},{"cvss_score":5.9,"headline":"SimpleSAMLphp Invalid token creation and validation","id":"CVE-2017-12867","kev_date_added":null,"published":"2017-08-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can bypass SAML signature verification to impersonate users, requiring an upgrade of the SimpleSAMLphp library.","url":"https://insights.sbomify.com/CVE-2018-7644/"}