# CVE-2018-7644: SimpleSAMLphp Improper Verification of Cryptographic Signature

> Attackers can bypass SAML signature verification to impersonate users, requiring an upgrade of the SimpleSAMLphp library.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Mar 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-7644, GHSA-923w-2xv2-7pr8, UBUNTU-CVE-2018-7644

## What is CVE-2018-7644?

CVE-2018-7644 is a high-severity authentication bypass vulnerability in n/a, published on 5 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The XmlSecLibs library as used in the saml2 library in SimpleSAMLphp before 1.15.3 incorrectly verifies signatures on SAML assertions, allowing a remote attacker to construct a crafted SAML assertion on behalf of an Identity Provider that would pass as cryptographically valid, thereby allowing them to impersonate a user from that Identity Provider, aka a key confusion issue.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2018-7644?

6 open source packages ship an affected version, including simplesamlphp/saml2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `simplesamlphp/saml2` | Packagist | All versions | 1.10.5 |
| `simplesamlphp/saml2` | Packagist | All versions | 1.10.5 |
| `simplesamlphp/saml2` | Packagist | From 2.0 | 2.3.7 |
| `simplesamlphp/saml2` | Packagist | From 2.0 | 2.3.7 |
| `simplesamlphp/saml2` | Packagist | From 3.0 | 3.1.3 |
| `simplesamlphp/saml2` | Packagist | From 3.0 | 3.1.3 |

Products: Simplesamlphp Simplesamlphp.

## How do I fix CVE-2018-7644?

Upgrade simplesamlphp/saml2 to a fixed version for your release line: 1.10.5, 2.3.7 or 3.1.3.

## Is CVE-2018-7644 being exploited?

There is no known exploitation of CVE-2018-7644 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2017-12868](https://insights.sbomify.com/CVE-2017-12868/): SimpleSAMLphp Session fixation issue and authentication bypass in the authcrypt module (critical 9.8)
- [CVE-2026-49284](https://insights.sbomify.com/CVE-2026-49284/): SimpleSAMLphp SP accepts a response from an unexpected IdP when unsigned `Response/InResponseTo` is combined with a signed assertion lacking `SubjectConfirmationData/InResponseTo` (high 7.1)
- [CVE-2018-6520](https://insights.sbomify.com/CVE-2018-6520/): SimpleSAMLphp Open redirection protection bypass (medium 6.1)
- [CVE-2017-12870](https://insights.sbomify.com/CVE-2017-12870/): SimpleSAMLphp Unauthenticated encryption in CBC mode (medium 5.9)
- [CVE-2017-12871](https://insights.sbomify.com/CVE-2017-12871/): SimpleSAMLphp Incorrect IV generation for encryption (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-7644 and fix it if it is affected.

What it is: CVE-2018-7644 is a high-severity authentication bypass vulnerability in n/a, published on 5 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-7644 in the wild and no public exploit code.

Affected packages and fixed versions:
- simplesamlphp/saml2 (Packagist): affected all versions; fixed in 1.10.5
- simplesamlphp/saml2 (Packagist): affected all versions; fixed in 1.10.5
- simplesamlphp/saml2 (Packagist): affected from 2.0; fixed in 2.3.7
- simplesamlphp/saml2 (Packagist): affected from 2.0; fixed in 2.3.7
- simplesamlphp/saml2 (Packagist): affected from 3.0; fixed in 3.1.3
- simplesamlphp/saml2 (Packagist): affected from 3.0; fixed in 3.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-7644/ (Markdown: https://insights.sbomify.com/CVE-2018-7644/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-7644
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-7644
- OSV: https://osv.dev/vulnerability/CVE-2018-7644

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-7644/
Summaries are generated and may contain mistakes; the official description above is the record.
