{"answers":{"affected":"2 open source packages ship an affected version, including ssri. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-7651 in the wild and no public exploit code.","fix":"Upgrade ssri to 5.2.2 or later.","what":"CVE-2018-7651 is a medium-severity denial of service vulnerability in n/a, published on 4 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-7651 and fix it if it is affected.\n\nWhat it is: CVE-2018-7651 is a medium-severity denial of service vulnerability in n/a, published on 4 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-7651 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ssri (npm): affected all versions; fixed in 5.2.2\n- ssri (npm): affected all versions; fixed in 5.2.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-7651/ (Markdown: https://insights.sbomify.com/CVE-2018-7651/index.md)","id":"CVE-2018-7651","markdown":"https://insights.sbomify.com/CVE-2018-7651/index.md","name":"CVE-2018-7651","record":{"aliases":["DEBIAN-CVE-2018-7651","GHSA-325j-24f4-qv5x","UBUNTU-CVE-2018-7651"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Node.js ssri module","requires_auth":"none","summary":"An attacker can cause a denial of service in the ssri Node.js library by providing a long base64 hash string in strict mode.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ssri","vendor":"ssri_project"}],"cvss":{"score":5.9,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"index.js in the ssri module before 5.2.2 for Node.js is prone to a regular expression denial of service vulnerability in strict mode functionality via a long base64 hash string.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Regular Expression Denial of Service in ssri","id":"CVE-2018-7651","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2018"},"n_packages":2,"n_references":3,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2018-7652"},"packages":[{"ecosystem":"npm","fixed":["5.2.2"],"introduced":["0"],"last_affected":[],"package":"ssri","purl":null,"source":"GHSA-325j-24f4-qv5x"},{"ecosystem":"npm","fixed":["5.2.2"],"introduced":["0"],"last_affected":[],"package":"ssri","purl":"pkg:npm/ssri","source":"GHSA-325j-24f4-qv5x"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2018-7650"},"products":["n/a"],"published":"2018-03-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"An attacker can cause a denial of service in the ssri Node.js library by providing a long base64 hash string in strict mode.","url":"https://insights.sbomify.com/CVE-2018-7651/"}