# CVE-2018-7651: Regular Expression Denial of Service in ssri

> An attacker can cause a denial of service in the ssri Node.js library by providing a long base64 hash string in strict mode.

- **Severity:** Medium 5.9 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Mar 2018
- **Updated:** 16 Sep 2024
- **Also known as:** DEBIAN-CVE-2018-7651, GHSA-325j-24f4-qv5x, UBUNTU-CVE-2018-7651

## What is CVE-2018-7651?

CVE-2018-7651 is a medium-severity denial of service vulnerability in n/a, published on 4 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

index.js in the ssri module before 5.2.2 for Node.js is prone to a regular expression denial of service vulnerability in strict mode functionality via a long base64 hash string.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2018-7651?

2 open source packages ship an affected version, including ssri. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ssri` | npm | All versions | 5.2.2 |
| `ssri` | npm | All versions | 5.2.2 |

Products: Ssri Project Ssri.

## How do I fix CVE-2018-7651?

Upgrade ssri to 5.2.2 or later.

## Is CVE-2018-7651 being exploited?

There is no known exploitation of CVE-2018-7651 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-7651 and fix it if it is affected.

What it is: CVE-2018-7651 is a medium-severity denial of service vulnerability in n/a, published on 4 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-7651 in the wild and no public exploit code.

Affected packages and fixed versions:
- ssri (npm): affected all versions; fixed in 5.2.2
- ssri (npm): affected all versions; fixed in 5.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-7651/ (Markdown: https://insights.sbomify.com/CVE-2018-7651/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-7651
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-7651
- OSV: https://osv.dev/vulnerability/CVE-2018-7651

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-7651/
Summaries are generated and may contain mistakes; the official description above is the record.
