# CVE-2018-7667: vrana/adminer vulnerable to SSRF by connecting to privileged ports

> Adminer allows Server-Side Request Forgery via the server parameter, enabling attackers to access internal resources.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Mar 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-7667, DLA-1311-1, GHSA-43f8-p5w3-5m25, UBUNTU-CVE-2018-7667

## What is CVE-2018-7667?

CVE-2018-7667 is a critical server-side request forgery vulnerability in n/a, published on 5 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Adminer through 4.3.1 has SSRF via the server parameter.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2018-7667?

2 open source packages ship an affected version, including vrana/adminer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vrana/adminer` | Packagist | All versions | 4.7.8 |
| `vrana/adminer` | Packagist | All versions | 4.7.8 |

Products: Adminer Adminer.

## How do I fix CVE-2018-7667?

Upgrade vrana/adminer to 4.7.8 or later.

## Is CVE-2018-7667 being exploited?

There is no known exploitation of CVE-2018-7667 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-21311](https://insights.sbomify.com/CVE-2021-21311/): Adminer Server-Side Request Forgery (high 7.2, exploited in the wild)
- [CVE-2025-43960](https://insights.sbomify.com/CVE-2025-43960/): Adminer PHP Object Injection issue leads to Denial of Service (high 8.6)
- [CVE-2026-25892](https://insights.sbomify.com/CVE-2026-25892/): Adminer has an Unauthenticated Persistent DoS via Array Injection in ?script=version Endpoint (high 7.5)
- [CVE-2021-43008](https://insights.sbomify.com/CVE-2021-43008/): Files or Directories Accessible to External Parties in Adminer (high 7.5)
- [CVE-2021-29625](https://insights.sbomify.com/CVE-2021-29625/): XSS in doc_link (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-7667 and fix it if it is affected.

What it is: CVE-2018-7667 is a critical server-side request forgery vulnerability in n/a, published on 5 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-7667 in the wild and no public exploit code.

Affected packages and fixed versions:
- vrana/adminer (Packagist): affected all versions; fixed in 4.7.8
- vrana/adminer (Packagist): affected all versions; fixed in 4.7.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-7667/ (Markdown: https://insights.sbomify.com/CVE-2018-7667/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-7667
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-7667
- OSV: https://osv.dev/vulnerability/CVE-2018-7667

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-7667/
Summaries are generated and may contain mistakes; the official description above is the record.
