CVE-2018-7711 SimpleSAMLphp saml2 incorrect signature validation
Attackers can bypass SAML signature validation by forcing errors that are incorrectly treated as valid, compromising authentication integrity.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2018-7711?
CVE-2018-7711 is a high-severity vulnerability in Debian Debian Linux, published on 5 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
HTTPRedirect.php in the saml2 library in SimpleSAMLphp before 1.15.4 has an incorrect check of return values in the signature validation utilities, allowing an attacker to get invalid signatures accepted as valid by forcing an error during validation. This occurs because of a dependency on PHP functionality that interprets a -1 error code as a true boolean value.
Weakness: CWE-347
Which versions are affected by CVE-2018-7711?
6 open source packages ship an affected version, including simplesamlphp/saml2. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
simplesamlphp/saml2 Packagist | All versions | 1.10.6 |
simplesamlphp/saml2 Packagist | All versions | 1.10.6 |
simplesamlphp/saml2 Packagist | From 2.0 | 2.3.8 |
simplesamlphp/saml2 Packagist | From 2.0 | 2.3.8 |
simplesamlphp/saml2 Packagist | From 3.0 | 3.1.4 |
simplesamlphp/saml2 Packagist | From 3.0 | 3.1.4 |
Products include Debian Debian Linux, Simplesamlphp Saml2, Simplesamlphp Simplesamlphp.
How do I fix CVE-2018-7711?
Upgrade simplesamlphp/saml2 to a fixed version for your release line: 1.10.6, 2.3.8 or 3.1.4.
Is CVE-2018-7711 being exploited?
There is no known exploitation of CVE-2018-7711 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2018-7711, DLA-1314-1, GHSA-g888-g2pp-82hf, UBUNTU-CVE-2018-7711.