{"answers":{"affected":"6 open source packages ship an affected version, including simplesamlphp/saml2. It affects 3 products.","exploited":"There is no known exploitation of CVE-2018-7711 in the wild and no public exploit code.","fix":"Upgrade simplesamlphp/saml2 to a fixed version for your release line: 1.10.6, 2.3.8 or 3.1.4.","what":"CVE-2018-7711 is a high-severity vulnerability in Debian Debian Linux, published on 5 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-7711 and fix it if it is affected.\n\nWhat it is: CVE-2018-7711 is a high-severity vulnerability in Debian Debian Linux, published on 5 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-7711 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- simplesamlphp/saml2 (Packagist): affected all versions; fixed in 1.10.6\n- simplesamlphp/saml2 (Packagist): affected all versions; fixed in 1.10.6\n- simplesamlphp/saml2 (Packagist): affected from 2.0; fixed in 2.3.8\n- simplesamlphp/saml2 (Packagist): affected from 2.0; fixed in 2.3.8\n- simplesamlphp/saml2 (Packagist): affected from 3.0; fixed in 3.1.4\n- simplesamlphp/saml2 (Packagist): affected from 3.0; fixed in 3.1.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-7711/ (Markdown: https://insights.sbomify.com/CVE-2018-7711/index.md)","id":"CVE-2018-7711","markdown":"https://insights.sbomify.com/CVE-2018-7711/index.md","name":"CVE-2018-7711","record":{"aliases":["DEBIAN-CVE-2018-7711","DLA-1314-1","GHSA-g888-g2pp-82hf","UBUNTU-CVE-2018-7711"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"SAML2 authentication library","requires_auth":"none","summary":"Attackers can bypass SAML signature validation by forcing errors that are incorrectly treated as valid, compromising authentication integrity.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"saml2","vendor":"simplesamlphp"},{"product":"simplesamlphp","vendor":"simplesamlphp"}],"cvss":{"score":8.1,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-347","name":"Improper Verification of Cryptographic Signature"}],"description":"HTTPRedirect.php in the saml2 library in SimpleSAMLphp before 1.15.4 has an incorrect check of return values in the signature validation utilities, allowing an attacker to get invalid signatures accepted as valid by forcing an error during validation. This occurs because of a dependency on PHP functionality that interprets a -1 error code as a true boolean value.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"SimpleSAMLphp saml2 incorrect signature validation","id":"CVE-2018-7711","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"debian:debian_linux","products":["debian:debian_linux"],"type":"security_feature_bypass","year":"2018"},"n_packages":6,"n_references":3,"next":{"headline":"Denial of service in n/a","id":"CVE-2018-7712"},"packages":[{"ecosystem":"Packagist","fixed":["1.10.6"],"introduced":["0"],"last_affected":[],"package":"simplesamlphp/saml2","purl":null,"source":"GHSA-g888-g2pp-82hf"},{"ecosystem":"Packagist","fixed":["1.10.6"],"introduced":["0"],"last_affected":[],"package":"simplesamlphp/saml2","purl":"pkg:composer/simplesamlphp/saml2","source":"GHSA-g888-g2pp-82hf"},{"ecosystem":"Packagist","fixed":["2.3.8"],"introduced":["2.0"],"last_affected":[],"package":"simplesamlphp/saml2","purl":null,"source":"GHSA-g888-g2pp-82hf"},{"ecosystem":"Packagist","fixed":["2.3.8"],"introduced":["2.0"],"last_affected":[],"package":"simplesamlphp/saml2","purl":"pkg:composer/simplesamlphp/saml2","source":"GHSA-g888-g2pp-82hf"},{"ecosystem":"Packagist","fixed":["3.1.4"],"introduced":["3.0"],"last_affected":[],"package":"simplesamlphp/saml2","purl":null,"source":"GHSA-g888-g2pp-82hf"},{"ecosystem":"Packagist","fixed":["3.1.4"],"introduced":["3.0"],"last_affected":[],"package":"simplesamlphp/saml2","purl":"pkg:composer/simplesamlphp/saml2","source":"GHSA-g888-g2pp-82hf"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2018-7707"},"products":["n/a"],"published":"2018-03-05","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can bypass SAML signature validation by forcing errors that are incorrectly treated as valid, compromising authentication integrity.","url":"https://insights.sbomify.com/CVE-2018-7711/"}