# CVE-2018-7711: SimpleSAMLphp saml2 incorrect signature validation

> Attackers can bypass SAML signature validation by forcing errors that are incorrectly treated as valid, compromising authentication integrity.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Mar 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-7711, DLA-1314-1, GHSA-g888-g2pp-82hf, UBUNTU-CVE-2018-7711

## What is CVE-2018-7711?

CVE-2018-7711 is a high-severity vulnerability in Debian Debian Linux, published on 5 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

HTTPRedirect.php in the saml2 library in SimpleSAMLphp before 1.15.4 has an incorrect check of return values in the signature validation utilities, allowing an attacker to get invalid signatures accepted as valid by forcing an error during validation. This occurs because of a dependency on PHP functionality that interprets a -1 error code as a true boolean value.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2018-7711?

6 open source packages ship an affected version, including simplesamlphp/saml2. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `simplesamlphp/saml2` | Packagist | All versions | 1.10.6 |
| `simplesamlphp/saml2` | Packagist | All versions | 1.10.6 |
| `simplesamlphp/saml2` | Packagist | From 2.0 | 2.3.8 |
| `simplesamlphp/saml2` | Packagist | From 2.0 | 2.3.8 |
| `simplesamlphp/saml2` | Packagist | From 3.0 | 3.1.4 |
| `simplesamlphp/saml2` | Packagist | From 3.0 | 3.1.4 |

Products: Debian Debian Linux, Simplesamlphp Saml2, Simplesamlphp Simplesamlphp.

## How do I fix CVE-2018-7711?

Upgrade simplesamlphp/saml2 to a fixed version for your release line: 1.10.6, 2.3.8 or 3.1.4.

## Is CVE-2018-7711 being exploited?

There is no known exploitation of CVE-2018-7711 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-7711 and fix it if it is affected.

What it is: CVE-2018-7711 is a high-severity vulnerability in Debian Debian Linux, published on 5 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-7711 in the wild and no public exploit code.

Affected packages and fixed versions:
- simplesamlphp/saml2 (Packagist): affected all versions; fixed in 1.10.6
- simplesamlphp/saml2 (Packagist): affected all versions; fixed in 1.10.6
- simplesamlphp/saml2 (Packagist): affected from 2.0; fixed in 2.3.8
- simplesamlphp/saml2 (Packagist): affected from 2.0; fixed in 2.3.8
- simplesamlphp/saml2 (Packagist): affected from 3.0; fixed in 3.1.4
- simplesamlphp/saml2 (Packagist): affected from 3.0; fixed in 3.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-7711/ (Markdown: https://insights.sbomify.com/CVE-2018-7711/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-7711
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-7711
- OSV: https://osv.dev/vulnerability/CVE-2018-7711

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-7711/
Summaries are generated and may contain mistakes; the official description above is the record.
