# CVE-2018-7749: AsyncSSH SSH Server Authentication Bypass

> Attackers can bypass authentication in AsyncSSH by skipping the authentication step, allowing unauthorized access to the SSH server.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Mar 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-7749, GHSA-97cv-6pjf-5f9q, PYSEC-2018-108, UBUNTU-CVE-2018-7749, USN-4854-1

## What is CVE-2018-7749?

CVE-2018-7749 is a critical authentication bypass vulnerability in n/a, published on 12 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The SSH server implementation of AsyncSSH before 1.12.1 does not properly check whether authentication is completed before processing other requests. A customized SSH client can simply skip the authentication step.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2018-7749?

3 open source packages ship an affected version, including asyncssh and AsyncSSH. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `asyncssh` | PyPI | All versions | 1.12.1 |
| `asyncssh` | PyPI | All versions | 1.12.1 |
| `AsyncSSH` | PyPI | All versions | 1.12.1 |

Products: Asyncssh Project Asyncssh.

## How do I fix CVE-2018-7749?

Upgrade asyncssh to 1.12.1 or later.

## Is CVE-2018-7749 being exploited?

There is no known exploitation of CVE-2018-7749 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-45309](https://insights.sbomify.com/CVE-2026-45309/): AsyncSSH `AuthorizedKeysFile %u` path traversal allows attacker-selected authorized keys to authenticate a traversal username (high 8.2)
- [CVE-2023-46446](https://insights.sbomify.com/CVE-2023-46446/): AsyncSSH Rogue Session Attack (medium 6.8)
- [CVE-2023-46445](https://insights.sbomify.com/CVE-2023-46445/): AsyncSSH Rogue Extension Negotiation (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-7749 and fix it if it is affected.

What it is: CVE-2018-7749 is a critical authentication bypass vulnerability in n/a, published on 12 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-7749 in the wild and no public exploit code.

Affected packages and fixed versions:
- asyncssh (PyPI): affected all versions; fixed in 1.12.1
- asyncssh (PyPI): affected all versions; fixed in 1.12.1
- AsyncSSH (PyPI): affected all versions; fixed in 1.12.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-7749/ (Markdown: https://insights.sbomify.com/CVE-2018-7749/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-7749
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-7749
- OSV: https://osv.dev/vulnerability/CVE-2018-7749

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-7749/
Summaries are generated and may contain mistakes; the official description above is the record.
