# CVE-2018-7753: Bleach URI Scheme Restriction Bypass

> Attackers can bypass URI sanitization in Bleach using character entities to inject malicious scripts, leading to cross-site scripting attacks.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Mar 2018
- **Updated:** 17 Sep 2024
- **Also known as:** DEBIAN-CVE-2018-7753, GHSA-m9mq-p2f9-cfqv, PYSEC-2018-51, UBUNTU-CVE-2018-7753

## What is CVE-2018-7753?

CVE-2018-7753 is a critical cross-site scripting vulnerability in n/a, published on 7 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in Bleach 2.1.x before 2.1.3. Attributes that have URI values weren't properly sanitized if the values contained character entities. Using character entities, it was possible to construct a URI value with a scheme that was not allowed that would slide through unsanitized.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2018-7753?

3 open source packages ship an affected version, including bleach. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bleach` | PyPI | From 2.1 | 2.1.3 |
| `bleach` | PyPI | From 2.1.0 | 2.1.3 |
| `bleach` | PyPI | From 2.1.0 | 2.1.3 |

Products: Mozilla Bleach.

## How do I fix CVE-2018-7753?

Upgrade bleach to 2.1.3 or later.

## Is CVE-2018-7753 being exploited?

There is no known exploitation of CVE-2018-7753 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-6817](https://insights.sbomify.com/CVE-2020-6817/): regular expression denial-of-service (ReDoS) in Bleach (high 7.5)
- [CVE-2021-23980](https://insights.sbomify.com/CVE-2021-23980/): Cross-site scripting in Bleach (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-7753 and fix it if it is affected.

What it is: CVE-2018-7753 is a critical cross-site scripting vulnerability in n/a, published on 7 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-7753 in the wild and no public exploit code.

Affected packages and fixed versions:
- bleach (PyPI): affected from 2.1; fixed in 2.1.3
- bleach (PyPI): affected from 2.1.0; fixed in 2.1.3
- bleach (PyPI): affected from 2.1.0; fixed in 2.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-7753/ (Markdown: https://insights.sbomify.com/CVE-2018-7753/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-7753
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-7753
- OSV: https://osv.dev/vulnerability/CVE-2018-7753

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-7753/
Summaries are generated and may contain mistakes; the official description above is the record.
