CVE-2018-8004 Other in Apache Traffic Server

Medium 6.5 Published Updated

Attackers can exploit HTTP smuggling and cache poisoning flaws in Apache Traffic Server to manipulate cached content and bypass security controls.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2018-8004?

CVE-2018-8004 is a medium-severity vulnerability in Apache Traffic Server, published on 29 Aug 2018. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

There are multiple HTTP smuggling and cache poisoning issues when clients making malicious requests interact with Apache Traffic Server (ATS). This affects versions 6.0.0 to 6.2.2 and 7.0.0 to 7.1.3. To resolve this issue users running 6.x should upgrade to 6.2.3 or later versions and 7.x users should upgrade to 7.1.4 or later versions.

Weakness: CWE-444

Which versions are affected by CVE-2018-8004?

It affects 2 products.

Products include Apache Traffic Server, Debian Debian Linux.

How do I fix CVE-2018-8004?

Upgrade to a fixed version.

Is CVE-2018-8004 being exploited?

There is no known exploitation of CVE-2018-8004 in the wild and no public exploit code.

Public exploit code: 1 proofs of concept on GitHub.

All Apache Traffic Server vulnerabilities

Sources

Also known as DEBIAN-CVE-2018-8004, GHSA-whhq-69jf-g65h, UBUNTU-CVE-2018-8004.

Is CVE-2018-8004 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free