CVE-2018-8005 Denial of service in Apache Traffic Server

Medium 5.3 Published Updated

Attackers can cause performance degradation or denial of service by sending multiple range requests for large cached objects in Apache Traffic Server.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2018-8005?

CVE-2018-8005 is a medium-severity denial of service vulnerability in Apache Traffic Server, published on 29 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

When there are multiple ranges in a range request, Apache Traffic Server (ATS) will read the entire object from cache. This can cause performance problems with large objects in cache. This affects versions 6.0.0 to 6.2.2 and 7.0.0 to 7.1.3. To resolve this issue users running 6.x users should upgrade to 6.2.3 or later versions and 7.x users should upgrade to 7.1.4 or later versions.

Weakness: CWE-400

Which versions are affected by CVE-2018-8005?

It affects 2 products.

Products include Apache Traffic Server, Debian Debian Linux.

How do I fix CVE-2018-8005?

Upgrade to a fixed version.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2018-8005 being exploited?

There is no known exploitation of CVE-2018-8005 in the wild and no public exploit code.

All Apache Traffic Server vulnerabilities

Sources

Also known as DEBIAN-CVE-2018-8005, GHSA-98hg-h5w7-368p, UBUNTU-CVE-2018-8005.

Is CVE-2018-8005 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free