# CVE-2018-8005: Denial of service in Apache Traffic Server

> Attackers can cause performance degradation or denial of service by sending multiple range requests for large cached objects in Apache Traffic Server.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Aug 2018
- **Updated:** 16 Sep 2024
- **Also known as:** DEBIAN-CVE-2018-8005, GHSA-98hg-h5w7-368p, UBUNTU-CVE-2018-8005

## What is CVE-2018-8005?

CVE-2018-8005 is a medium-severity denial of service vulnerability in Apache Traffic Server, published on 29 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

When there are multiple ranges in a range request, Apache Traffic Server (ATS) will read the entire object from cache. This can cause performance problems with large objects in cache. This affects versions 6.0.0 to 6.2.2 and 7.0.0 to 7.1.3. To resolve this issue users running 6.x users should upgrade to 6.2.3 or later versions and 7.x users should upgrade to 7.1.4 or later versions.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2018-8005?

It affects 2 products.


Products: Apache Traffic Server, Debian Debian Linux.

## How do I fix CVE-2018-8005?

Upgrade to a fixed version.

## Is CVE-2018-8005 being exploited?

There is no known exploitation of CVE-2018-8005 in the wild and no public exploit code.

## Other vulnerabilities in Apache Traffic Server

- [CVE-2014-3525](https://insights.sbomify.com/CVE-2014-3525/): Other in n/a (critical 10.0)
- [CVE-2021-43082](https://insights.sbomify.com/CVE-2021-43082/): heap-buffer-overflow with stats-over-http plugin (critical 9.8)
- [CVE-2021-35474](https://insights.sbomify.com/CVE-2021-35474/): Dynamic stack buffer overflow in cachekey plugin (critical 9.8)
- [CVE-2019-17559](https://insights.sbomify.com/CVE-2019-17559/): Other in Apache Traffic Server (critical 9.8)
- [CVE-2019-17565](https://insights.sbomify.com/CVE-2019-17565/): Other in Apache Traffic Server (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-8005 and fix it if it is affected.

What it is: CVE-2018-8005 is a medium-severity denial of service vulnerability in Apache Traffic Server, published on 29 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-8005 in the wild and no public exploit code.

Affected product: Apache Traffic Server. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-8005/ (Markdown: https://insights.sbomify.com/CVE-2018-8005/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-8005
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-8005
- OSV: https://osv.dev/vulnerability/CVE-2018-8005

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-8005/
Summaries are generated and may contain mistakes; the official description above is the record.
