# CVE-2018-8006: Apache ActiveMQ web console vulnerable to Cross-site Scripting

> Cross-site scripting in the ActiveMQ web console allows attackers to execute scripts in victim browsers via the QueueFilter parameter.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Oct 2018
- **Updated:** 16 Sep 2024
- **Also known as:** DEBIAN-CVE-2018-8006, GHSA-hvwm-2624-rp9x, UBUNTU-CVE-2018-8006

## What is CVE-2018-8006?

CVE-2018-8006 is a medium-severity cross-site scripting vulnerability in Apache Activemq, published on 10 Oct 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An instance of a cross-site scripting vulnerability was identified to be present in the web based administration console on the queue.jsp page of Apache ActiveMQ versions 5.0.0 to 5.15.5. The root cause of this issue is improper data filtering of the QueueFilter parameter.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-8006?

2 open source packages ship an affected version, including org.apache.activemq:activemq-web-console. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.activemq:activemq-web-console` | Maven | From 5.0.0 | 5.15.6 |
| `org.apache.activemq:activemq-web-console` | Maven | From 5.0.0 | 5.15.6 |

Products: Apache Activemq.

## How do I fix CVE-2018-8006?

Upgrade org.apache.activemq:activemq-web-console to 5.15.6 or later.

## Is CVE-2018-8006 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2018-8006 exists.

Public exploit code:

- Apache ActiveMQ <=5.15.5 - Cross-Site Scripting (nuclei): http/cves/2018/CVE-2018-8006.yaml

## Other vulnerabilities in Apache Activemq

- [CVE-2023-46604](https://insights.sbomify.com/CVE-2023-46604/): Apache ActiveMQ Deserialization of Untrusted Data (critical 10.0, exploited in the wild)
- [CVE-2016-3088](https://insights.sbomify.com/CVE-2016-3088/): Apache ActiveMQ Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2026-34197](https://insights.sbomify.com/CVE-2026-34197/): Apache ActiveMQ Improper Input Validation (high 8.8, exploited in the wild)
- [CVE-2020-11998](https://insights.sbomify.com/CVE-2020-11998/): Remote code execution in Apache ActiveMQ (critical 9.8)
- [CVE-2013-7285](https://insights.sbomify.com/CVE-2013-7285/): Command Injection in Xstream (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-8006 and fix it if it is affected.

What it is: CVE-2018-8006 is a medium-severity cross-site scripting vulnerability in Apache Activemq, published on 10 Oct 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2018-8006 exists.

Affected packages and fixed versions:
- org.apache.activemq:activemq-web-console (Maven): affected from 5.0.0; fixed in 5.15.6
- org.apache.activemq:activemq-web-console (Maven): affected from 5.0.0; fixed in 5.15.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-8006/ (Markdown: https://insights.sbomify.com/CVE-2018-8006/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-8006
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-8006
- OSV: https://osv.dev/vulnerability/CVE-2018-8006

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-8006/
Summaries are generated and may contain mistakes; the official description above is the record.
