CVE-2018-8008 ZipSlip in org.apache.storm:storm-core
Attackers can write arbitrary files outside the intended directory via crafted archives, potentially compromising the Apache Storm server.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2018-8008?
CVE-2018-8008 is a medium-severity path traversal vulnerability in Apache Storm, published on 5 Jun 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
Apache Storm version 1.0.6 and earlier, 1.2.1 and earlier, and version 1.1.2 and earlier expose an arbitrary file write vulnerability, that can be achieved using a specially crafted zip archive (affects other archives as well, bzip2, tar, xz, war, cpio, 7z), that holds path traversal filenames. So when the filename gets concatenated to the target extraction directory, the final path ends up outside of the target folder.
Weakness: CWE-22
Which versions are affected by CVE-2018-8008?
6 open source packages ship an affected version, including org.apache.storm:storm-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.storm:storm-core Maven | All versions | 1.0.7 |
org.apache.storm:storm-core Maven | All versions | 1.0.7 |
org.apache.storm:storm-core Maven | From 1.1.0 | 1.1.3 |
org.apache.storm:storm-core Maven | From 1.1.0 | 1.1.3 |
org.apache.storm:storm-core Maven | From 1.2.0 | 1.2.2 |
org.apache.storm:storm-core Maven | From 1.2.0 | 1.2.2 |
Products include Apache Storm.
How do I fix CVE-2018-8008?
Upgrade org.apache.storm:storm-core to a fixed version for your release line: 1.0.7, 1.1.3 or 1.2.2.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2018-8008 being exploited?
There is no known exploitation of CVE-2018-8008 in the wild and no public exploit code.
Other vulnerabilities in Apache Storm
- CVE-2021-38294 Shell Command Injection Vulnerability in Nimbus Thrift Server
- CVE-2021-40865 Unsafe Pre-Authentication Deserialization In Workers
- CVE-2018-11779 Deserialization of Untrusted Data in Apache Storm
- CVE-2015-3188 Apache Storm remote code execution vulnerability
- CVE-2026-35337 Apache Storm Client: RCE through Unsafe Deserialization via Kerberos TGT Credential Handling
Sources
Also known as GHSA-898j-5cc8-cmf5.