# CVE-2018-8008: ZipSlip in org.apache.storm:storm-core

> Attackers can write arbitrary files outside the intended directory via crafted archives, potentially compromising the Apache Storm server.

- **Severity:** Medium 5.5 (`CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Jun 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-898j-5cc8-cmf5

## What is CVE-2018-8008?

CVE-2018-8008 is a medium-severity path traversal vulnerability in Apache Storm, published on 5 Jun 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Apache Storm version 1.0.6 and earlier, 1.2.1 and earlier, and version 1.1.2 and earlier expose an arbitrary file write vulnerability, that can be achieved using a specially crafted zip archive (affects other archives as well, bzip2, tar, xz, war, cpio, 7z), that holds path traversal filenames. So when the filename gets concatenated to the target extraction directory, the final path ends up outside of the target folder.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2018-8008?

6 open source packages ship an affected version, including org.apache.storm:storm-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.storm:storm-core` | Maven | All versions | 1.0.7 |
| `org.apache.storm:storm-core` | Maven | All versions | 1.0.7 |
| `org.apache.storm:storm-core` | Maven | From 1.1.0 | 1.1.3 |
| `org.apache.storm:storm-core` | Maven | From 1.1.0 | 1.1.3 |
| `org.apache.storm:storm-core` | Maven | From 1.2.0 | 1.2.2 |
| `org.apache.storm:storm-core` | Maven | From 1.2.0 | 1.2.2 |

Products: Apache Storm.

## How do I fix CVE-2018-8008?

Upgrade org.apache.storm:storm-core to a fixed version for your release line: 1.0.7, 1.1.3 or 1.2.2.

## Is CVE-2018-8008 being exploited?

There is no known exploitation of CVE-2018-8008 in the wild and no public exploit code.

## Other vulnerabilities in Apache Storm

- [CVE-2021-38294](https://insights.sbomify.com/CVE-2021-38294/): Shell Command Injection Vulnerability in Nimbus Thrift Server (critical 9.8)
- [CVE-2021-40865](https://insights.sbomify.com/CVE-2021-40865/): Unsafe Pre-Authentication Deserialization In Workers (critical 9.8)
- [CVE-2018-11779](https://insights.sbomify.com/CVE-2018-11779/): Deserialization of Untrusted Data in Apache Storm (critical 9.8)
- [CVE-2015-3188](https://insights.sbomify.com/CVE-2015-3188/): Apache Storm remote code execution vulnerability (critical 9.8)
- [CVE-2026-35337](https://insights.sbomify.com/CVE-2026-35337/): Apache Storm Client: RCE through Unsafe Deserialization via Kerberos TGT Credential Handling (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-8008 and fix it if it is affected.

What it is: CVE-2018-8008 is a medium-severity path traversal vulnerability in Apache Storm, published on 5 Jun 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-8008 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.storm:storm-core (Maven): affected all versions; fixed in 1.0.7
- org.apache.storm:storm-core (Maven): affected all versions; fixed in 1.0.7
- org.apache.storm:storm-core (Maven): affected from 1.1.0; fixed in 1.1.3
- org.apache.storm:storm-core (Maven): affected from 1.1.0; fixed in 1.1.3
- org.apache.storm:storm-core (Maven): affected from 1.2.0; fixed in 1.2.2
- org.apache.storm:storm-core (Maven): affected from 1.2.0; fixed in 1.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-8008/ (Markdown: https://insights.sbomify.com/CVE-2018-8008/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-8008
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-8008
- OSV: https://osv.dev/vulnerability/CVE-2018-8008

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-8008/
Summaries are generated and may contain mistakes; the official description above is the record.
