# CVE-2018-8010: There is a XML external entity expansion (XXE) vulnerability in Apache Solr config files

> An attacker can exploit XML external entity expansion in Solr config files to read arbitrary local files or internal network resources.

- **Severity:** Medium 5.5 (`CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 May 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-rc9v-h28f-jcmf

## What is CVE-2018-8010?

CVE-2018-8010 is a medium-severity vulnerability in Apache Solr, published on 21 May 2018. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

This vulnerability in Apache Solr 6.0.0 to 6.6.3, 7.0.0 to 7.3.0 relates to an XML external entity expansion (XXE) in Solr config files (solrconfig.xml, schema.xml, managed-schema). In addition, Xinclude functionality provided in these config files is also affected in a similar way. The vulnerability can be used as XXE using file/ftp/http protocols in order to read arbitrary local files from the Solr server or the internal network. Users are advised to upgrade to either Solr 6.6.4 or Solr 7.3.1 releases both of which address the vulnerability. Once upgrade is complete, no other steps are required. Those releases only allow external entities and Xincludes that refer to local files / zookeeper resources below the Solr instance directory (using Solr's ResourceLoader); usage of absolute URLs is denied. Keep in mind, that external entities and XInclude are explicitly supported to better structure config files in large installations. Before Solr 6 this was no problem, as config files were not accessible through the APIs.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2018-8010?

4 open source packages ship an affected version, including org.apache.solr:solr-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.solr:solr-core` | Maven | From 6.6.0 | 6.6.4 |
| `org.apache.solr:solr-core` | Maven | From 6.6.0 | 6.6.4 |
| `org.apache.solr:solr-core` | Maven | From 7.0.0 | 7.3.1 |
| `org.apache.solr:solr-core` | Maven | From 7.0.0 | 7.3.1 |

Products: Apache Solr.

## How do I fix CVE-2018-8010?

Upgrade org.apache.solr:solr-core to a fixed version for your release line: 6.6.4 or 7.3.1.

## Is CVE-2018-8010 being exploited?

There is no known exploitation of CVE-2018-8010 in the wild and no public exploit code.

## Other vulnerabilities in Apache Solr

- [CVE-2019-17558](https://insights.sbomify.com/CVE-2019-17558/): Apache Solr VelocityResponseWriter Plug-In Remote Code Execution (high 7.5, exploited in the wild)
- [CVE-2019-0193](https://insights.sbomify.com/CVE-2019-0193/): Apache Solr DataImportHandler Code Injection (high 7.2, exploited in the wild)
- [CVE-2024-45216](https://insights.sbomify.com/CVE-2024-45216/): Apache Solr: Authentication bypass possible using a fake URL Path ending (critical 9.8)
- [CVE-2021-44548](https://insights.sbomify.com/CVE-2021-44548/): Apache Solr information disclosure vulnerability through DataImportHandler (critical 9.8)
- [CVE-2021-27905](https://insights.sbomify.com/CVE-2021-27905/): SSRF vulnerability with the Replication handler (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-8010 and fix it if it is affected.

What it is: CVE-2018-8010 is a medium-severity vulnerability in Apache Solr, published on 21 May 2018. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-8010 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.solr:solr-core (Maven): affected from 6.6.0; fixed in 6.6.4
- org.apache.solr:solr-core (Maven): affected from 6.6.0; fixed in 6.6.4
- org.apache.solr:solr-core (Maven): affected from 7.0.0; fixed in 7.3.1
- org.apache.solr:solr-core (Maven): affected from 7.0.0; fixed in 7.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-8010/ (Markdown: https://insights.sbomify.com/CVE-2018-8010/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-8010
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-8010
- OSV: https://osv.dev/vulnerability/CVE-2018-8010

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-8010/
Summaries are generated and may contain mistakes; the official description above is the record.
