# CVE-2018-8012: Missing Authorization in Apache ZooKeeper

> An attacker can join a ZooKeeper cluster without authentication to propagate counterfeit changes, requiring an upgrade to secure the quorum.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 May 2018
- **Updated:** 17 Sep 2024
- **Also known as:** DEBIAN-CVE-2018-8012, DSA-4214-1, GHSA-ccqf-c5hq-77mp, UBUNTU-CVE-2018-8012

## What is CVE-2018-8012?

CVE-2018-8012 is a high-severity missing authorization vulnerability in Debian Debian Linux, published on 21 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

No authentication/authorization is enforced when a server attempts to join a quorum in Apache ZooKeeper before 3.4.10, and 3.5.0-alpha through 3.5.3-beta. As a result an arbitrary end point could join the cluster and begin propagating counterfeit changes to the leader.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2018-8012?

4 open source packages ship an affected version, including org.apache.zookeeper:zookeeper. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.zookeeper:zookeeper` | Maven | All versions | 3.4.10 |
| `org.apache.zookeeper:zookeeper` | Maven | All versions | 3.4.10 |
| `org.apache.zookeeper:zookeeper` | Maven | From 3.5.0-alpha | 3.5.4-beta |
| `org.apache.zookeeper:zookeeper` | Maven | From 3.5.0-alpha | 3.5.4-beta |

Products: Apache Zookeeper, Debian Debian Linux, Oracle Goldengate Stream Analytics.

## How do I fix CVE-2018-8012?

Upgrade org.apache.zookeeper:zookeeper to a fixed version for your release line: 3.4.10 or 3.5.4-beta.

## Is CVE-2018-8012 being exploited?

There is no known exploitation of CVE-2018-8012 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2024-51504](https://insights.sbomify.com/CVE-2024-51504/): Apache ZooKeeper: Authentication bypass with IP-based authentication in Admin Server (critical 9.1)
- [CVE-2023-44981](https://insights.sbomify.com/CVE-2023-44981/): Apache ZooKeeper: Authorization bypass in SASL Quorum Peer Authentication (critical 9.1)
- [CVE-2016-5017](https://insights.sbomify.com/CVE-2016-5017/): Memory corruption in n/a (high 8.1)
- [CVE-2026-59739](https://insights.sbomify.com/CVE-2026-59739/): Apache ZooKeeper: Information disclosure via SetWatches reconnect replay (high 7.5)
- [CVE-2026-59969](https://insights.sbomify.com/CVE-2026-59969/): Apache ZooKeeper: Improper validation of certificate with host mismatch in FIPS mode (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-8012 and fix it if it is affected.

What it is: CVE-2018-8012 is a high-severity missing authorization vulnerability in Debian Debian Linux, published on 21 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-8012 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.zookeeper:zookeeper (Maven): affected all versions; fixed in 3.4.10
- org.apache.zookeeper:zookeeper (Maven): affected all versions; fixed in 3.4.10
- org.apache.zookeeper:zookeeper (Maven): affected from 3.5.0-alpha; fixed in 3.5.4-beta
- org.apache.zookeeper:zookeeper (Maven): affected from 3.5.0-alpha; fixed in 3.5.4-beta

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-8012/ (Markdown: https://insights.sbomify.com/CVE-2018-8012/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-8012
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-8012
- OSV: https://osv.dev/vulnerability/CVE-2018-8012

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-8012/
Summaries are generated and may contain mistakes; the official description above is the record.
