# CVE-2018-8013: Deserialization of Untrusted Data in Apache Batik

> An attacker can execute arbitrary code by exploiting unsafe deserialization in Apache Batik when processing malicious input streams.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 May 2018
- **Updated:** 16 Sep 2024
- **Also known as:** DEBIAN-CVE-2018-8013, DLA-1385-1, GHSA-25gw-4pcc-45cf, UBUNTU-CVE-2018-8013, USN-3661-1

## What is CVE-2018-8013?

CVE-2018-8013 is a critical unsafe deserialization vulnerability in Canonical Ubuntu Linux, published on 24 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Apache Batik 1.x before 1.10, when deserializing subclass of `AbstractDocument`, the class takes a string from the inputStream as the class name which then use it to call the no-arg constructor of the class. Fix was to check the class type before calling newInstance in deserialization.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2018-8013?

2 open source packages ship an affected version, including org.apache.xmlgraphics:batik. It affects 21 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.xmlgraphics:batik` | Maven | From 1.0 | 1.10 |
| `org.apache.xmlgraphics:batik` | Maven | From 1.0 | 1.10 |

Products: Apache Batik, Canonical Ubuntu Linux, Debian Debian Linux, Oracle Business Intelligence, Oracle Communications Diameter Signaling Router, Oracle Communications Metasolv Solution, Oracle Communications Webrtc Session Controller, Oracle Data Integrator, Oracle Enterprise Repository, Oracle Financial Services Analytical Applications Infrastructure, Oracle Fusion Middleware Mapviewer, Oracle Instantis Enterprisetrack, Oracle Insurance Calculation Engine, Oracle Insurance Policy Administration J2ee, Oracle Jd Edwards Enterpriseone Tools, Oracle Retail Back Office, Oracle Retail Central Office, Oracle Retail Integration Bus, Oracle Retail Order Broker, Oracle Retail Point-of-Service and 1 more.

## How do I fix CVE-2018-8013?

Upgrade org.apache.xmlgraphics:batik to 1.10 or later.

## Is CVE-2018-8013 being exploited?

There is no known exploitation of CVE-2018-8013 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11987](https://insights.sbomify.com/CVE-2020-11987/): Server-side request forgery (SSRF) in Apache Batik (high 8.2)
- [CVE-2022-41704](https://insights.sbomify.com/CVE-2022-41704/): Apache Batik prior to 1.16 allows RCE when loading untrusted SVG input (high 7.5)
- [CVE-2022-42890](https://insights.sbomify.com/CVE-2022-42890/): Apache Batik prior to 1.16 allows RCE via scripting (high 7.5)
- [CVE-2022-40146](https://insights.sbomify.com/CVE-2022-40146/): Jar url should be blocked by DefaultScriptSecurity (high 7.5)
- [CVE-2019-17566](https://insights.sbomify.com/CVE-2019-17566/): Server-side request forgery (SSRF) in Apache Batik (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-8013 and fix it if it is affected.

What it is: CVE-2018-8013 is a critical unsafe deserialization vulnerability in Canonical Ubuntu Linux, published on 24 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-8013 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.xmlgraphics:batik (Maven): affected from 1.0; fixed in 1.10
- org.apache.xmlgraphics:batik (Maven): affected from 1.0; fixed in 1.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-8013/ (Markdown: https://insights.sbomify.com/CVE-2018-8013/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-8013
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-8013
- OSV: https://osv.dev/vulnerability/CVE-2018-8013

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-8013/
Summaries are generated and may contain mistakes; the official description above is the record.
