{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.orc:orc. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-8015 in the wild and no public exploit code.","fix":"Upgrade org.apache.orc:orc to 1.4.4 or later.","what":"CVE-2018-8015 is a high-severity denial of service vulnerability in Apache ORC, published on 18 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-8015 and fix it if it is affected.\n\nWhat it is: CVE-2018-8015 is a high-severity denial of service vulnerability in Apache ORC, published on 18 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-8015 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.orc:orc (Maven): affected from 1.0.0; fixed in 1.4.4\n- org.apache.orc:orc (Maven): affected from 1.0.0; fixed in 1.4.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-8015/ (Markdown: https://insights.sbomify.com/CVE-2018-8015/index.md)","id":"CVE-2018-8015","markdown":"https://insights.sbomify.com/CVE-2018-8015/index.md","name":"CVE-2018-8015","record":{"aliases":["GHSA-mqmp-4mcp-vg8v"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache ORC library","requires_auth":"none","summary":"Attackers can cause denial of service by providing a malformed ORC file that triggers infinite recursion in the parser.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"orc","vendor":"apache"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-674","name":"Uncontrolled Recursion"}],"description":"In Apache ORC 1.0.0 to 1.4.3 a malformed ORC file can trigger an endlessly recursive function call in the C++ or Java parser. The impact of this bug is most likely denial-of-service against software that uses the ORC file parser. With the C++ parser, the stack overflow might possibly corrupt the stack.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache ORC vulnerable to Uncontrolled Recursion","id":"CVE-2018-8015","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"denial_of_service","year":"2018"},"n_packages":2,"n_references":2,"next":{"headline":"Missing Authentication for Critical Function in Apache Cassandra","id":"CVE-2018-8016"},"packages":[{"ecosystem":"Maven","fixed":["1.4.4"],"introduced":["1.0.0"],"last_affected":[],"package":"org.apache.orc:orc","purl":null,"source":"GHSA-mqmp-4mcp-vg8v"},{"ecosystem":"Maven","fixed":["1.4.4"],"introduced":["1.0.0"],"last_affected":[],"package":"org.apache.orc:orc","purl":"pkg:maven/org.apache.orc/orc","source":"GHSA-mqmp-4mcp-vg8v"}],"prev":{"headline":"The defaults settings for the CORS filter provided in Apache Tomcat are insecure and enable 'supportsCredentials' for all origins","id":"CVE-2018-8014"},"products":["Apache ORC"],"published":"2018-05-18","related":[{"cvss_score":6,"headline":"Apache ORC: Potential Heap Buffer Overflow during C++ LZO Decompression","id":"CVE-2025-47436","kev_date_added":null,"published":"2025-05-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["Apache Software Foundation"]},"summary":"Attackers can cause denial of service by providing a malformed ORC file that triggers infinite recursion in the parser.","url":"https://insights.sbomify.com/CVE-2018-8015/"}