# CVE-2018-8016: Missing Authentication for Critical Function in Apache Cassandra

> Remote attackers can execute arbitrary Java code via unauthenticated JMX/RMI interface in default Apache Cassandra configurations.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jun 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-52gq-7j6c-xw6x

## What is CVE-2018-8016?

CVE-2018-8016 is a critical authentication bypass vulnerability in Apache Cassandra, published on 28 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The default configuration in Apache Cassandra 3.8 through 3.11.1 binds an unauthenticated JMX/RMI interface to all network interfaces, which allows remote attackers to execute arbitrary Java code via an RMI request. This issue is a regression of CVE-2015-0225. The regression was introduced in https://issues.apache.org/jira/browse/CASSANDRA-12109. The fix for the regression is implemented in https://issues.apache.org/jira/browse/CASSANDRA-14173. This fix is contained in the 3.11.2 release of Apache Cassandra.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2018-8016?

2 open source packages ship an affected version, including org.apache.cassandra:cassandra-all. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.cassandra:cassandra-all` | Maven | From 3.8 | 3.11.2 |
| `org.apache.cassandra:cassandra-all` | Maven | From 3.8 | 3.11.2 |

Products: Apache Cassandra.

## How do I fix CVE-2018-8016?

Upgrade org.apache.cassandra:cassandra-all to 3.11.2 or later.

## Is CVE-2018-8016 being exploited?

There is no known exploitation of CVE-2018-8016 in the wild and no public exploit code.

## Other vulnerabilities in Apache Cassandra

- [CVE-2016-3427](https://insights.sbomify.com/CVE-2016-3427/): Oracle Java SE and JRockit Unspecified (critical 9.8, exploited in the wild)
- [CVE-2021-44521](https://insights.sbomify.com/CVE-2021-44521/): Remote code execution for scripted UDFs (critical 9.1)
- [CVE-2026-27314](https://insights.sbomify.com/CVE-2026-27314/): Apache Cassandra: Privilege escalation via ADD IDENTITY authorization bypass (high 8.8)
- [CVE-2025-26467](https://insights.sbomify.com/CVE-2025-26467/): Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actions (4.0.16 only) (high 8.8)
- [CVE-2025-23015](https://insights.sbomify.com/CVE-2025-23015/): Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actions (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-8016 and fix it if it is affected.

What it is: CVE-2018-8016 is a critical authentication bypass vulnerability in Apache Cassandra, published on 28 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-8016 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.cassandra:cassandra-all (Maven): affected from 3.8; fixed in 3.11.2
- org.apache.cassandra:cassandra-all (Maven): affected from 3.8; fixed in 3.11.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-8016/ (Markdown: https://insights.sbomify.com/CVE-2018-8016/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-8016
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-8016
- OSV: https://osv.dev/vulnerability/CVE-2018-8016

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-8016/
Summaries are generated and may contain mistakes; the official description above is the record.
