CVE-2018-8021 Deserialization of Untrusted Data in superset

Critical 9.8 Published Updated

An unsafe pickle deserialization vulnerability in Apache Superset allows attackers to execute arbitrary code remotely.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2018-8021?

CVE-2018-8021 is a critical unsafe deserialization vulnerability in Apache Superset, published on 7 Nov 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Versions of Superset prior to 0.23 used an unsafe load method from the pickle library to deserialize data leading to possible remote code execution. Note Superset 0.23 was released prior to any Superset release under the Apache Software Foundation.

Weakness: CWE-502

Which versions are affected by CVE-2018-8021?

3 open source packages ship an affected version, including superset. It affects 1 product.

PackageAffectedFixed in
superset PyPIAll versions0.23
superset PyPIAll versions0.23
superset PyPIAll versions0.23.0

Products include Apache Superset.

How do I fix CVE-2018-8021?

Upgrade superset to a fixed version for your release line: 0.23 or 0.23.0.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2018-8021 being exploited?

There is no known exploitation of CVE-2018-8021 in the wild and no public exploit code.

Public exploit code: 1 Exploit-DB entry and 1 proofs of concept on GitHub.

All Apache Superset vulnerabilities

Sources

Also known as GHSA-vxp9-wv2f-wqmw, PYSEC-2018-74.

Is CVE-2018-8021 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free