{"answers":{"affected":"3 open source packages ship an affected version, including superset. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-8021 in the wild and no public exploit code.","fix":"Upgrade superset to a fixed version for your release line: 0.23 or 0.23.0.","what":"CVE-2018-8021 is a critical unsafe deserialization vulnerability in Apache Superset, published on 7 Nov 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-8021 and fix it if it is affected.\n\nWhat it is: CVE-2018-8021 is a critical unsafe deserialization vulnerability in Apache Superset, published on 7 Nov 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-8021 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- superset (PyPI): affected all versions; fixed in 0.23\n- superset (PyPI): affected all versions; fixed in 0.23\n- superset (PyPI): affected all versions; fixed in 0.23.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-8021/ (Markdown: https://insights.sbomify.com/CVE-2018-8021/index.md)","id":"CVE-2018-8021","markdown":"https://insights.sbomify.com/CVE-2018-8021/index.md","name":"CVE-2018-8021","record":{"aliases":["GHSA-vxp9-wv2f-wqmw","PYSEC-2018-74"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Superset","requires_auth":"none","summary":"An unsafe pickle deserialization vulnerability in Apache Superset allows attackers to execute arbitrary code remotely.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"superset","vendor":"apache"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"Versions of Superset prior to 0.23 used an unsafe load method from the pickle library to deserialize data leading to possible remote code execution. Note Superset 0.23 was released prior to any Superset release under the Apache Software Foundation.","ecosystems":["PyPI"],"exploits":{"exploitdb":1,"first_seen":"2018-12-02","github_poc":1,"max_poc_stars":104,"metasploit":0,"nuclei":0,"refs":[{"date":"2018-12-02T19:01:17Z","kind":"github_poc","ref":"https://github.com/r3dxpl0it/Apache-Superset-Remote-Code-Execution-PoC-CVE-2018-8021","stars":104,"title":"CVE-2018-8021 Proof-Of-Concept and Exploit "},{"date":"2018-12-03","kind":"exploitdb","ref":"45933","stars":null,"title":"Apache Superset \u003c 0.23 - Remote Code Execution"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Deserialization of Untrusted Data in superset","id":"CVE-2018-8021","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"apache:superset","products":["apache:superset"],"type":"deserialization","year":"2018"},"n_packages":3,"n_references":2,"next":{"headline":"Denial of service in Apache Traffic Server","id":"CVE-2018-8022"},"packages":[{"ecosystem":"PyPI","fixed":["0.23"],"introduced":["0"],"last_affected":[],"package":"superset","purl":null,"source":"GHSA-vxp9-wv2f-wqmw"},{"ecosystem":"PyPI","fixed":["0.23"],"introduced":["0"],"last_affected":[],"package":"superset","purl":"pkg:pypi/superset","source":"GHSA-vxp9-wv2f-wqmw"},{"ecosystem":"PyPI","fixed":["0.23.0"],"introduced":["0"],"last_affected":[],"package":"superset","purl":"pkg:pypi/superset","source":"PYSEC-2018-74"}],"prev":{"headline":"Auth bypass in Apache Tomcat Native","id":"CVE-2018-8020"},"products":["Superset"],"published":"2018-11-07","related":[{"cvss_score":8.9,"headline":"Apache Superset Insecure Default Initialization of Resource","id":"CVE-2023-27524","kev_date_added":"2024-01-08","published":"2023-04-24"},{"cvss_score":9.8,"headline":"SQL injection vulnerability in chart data API","id":"CVE-2022-27479","kev_date_added":null,"published":"2022-04-13"},{"cvss_score":9.6,"headline":"Apache Superset: Stored XSS in Dashboard Title and Chart Title","id":"CVE-2023-49657","kev_date_added":null,"published":"2024-01-23"},{"cvss_score":8.8,"headline":"Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API","id":"CVE-2022-43719","kev_date_added":null,"published":"2023-01-16"},{"cvss_score":8.8,"headline":"Possible SQL Injection when template processing is enabled","id":"CVE-2021-41971","kev_date_added":null,"published":"2021-10-18"},{"cvss_score":8.8,"headline":"Apache Superset OS Command Injection","id":"CVE-2020-13948","kev_date_added":null,"published":"2020-09-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["unspecified"]},"summary":"An unsafe pickle deserialization vulnerability in Apache Superset allows attackers to execute arbitrary code remotely.","url":"https://insights.sbomify.com/CVE-2018-8021/"}