# CVE-2018-8021: Deserialization of Untrusted Data in superset

> An unsafe pickle deserialization vulnerability in Apache Superset allows attackers to execute arbitrary code remotely.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Nov 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-vxp9-wv2f-wqmw, PYSEC-2018-74

## What is CVE-2018-8021?

CVE-2018-8021 is a critical unsafe deserialization vulnerability in Apache Superset, published on 7 Nov 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of Superset prior to 0.23 used an unsafe load method from the pickle library to deserialize data leading to possible remote code execution. Note Superset 0.23 was released prior to any Superset release under the Apache Software Foundation.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2018-8021?

3 open source packages ship an affected version, including superset. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `superset` | PyPI | All versions | 0.23 |
| `superset` | PyPI | All versions | 0.23 |
| `superset` | PyPI | All versions | 0.23.0 |

Products: Apache Superset.

## How do I fix CVE-2018-8021?

Upgrade superset to a fixed version for your release line: 0.23 or 0.23.0.

## Is CVE-2018-8021 being exploited?

There is no known exploitation of CVE-2018-8021 in the wild and no public exploit code.

Public exploit code:

- CVE-2018-8021 Proof-Of-Concept and Exploit  (github_poc): https://github.com/r3dxpl0it/Apache-Superset-Remote-Code-Execution-PoC-CVE-2018-8021
- Apache Superset < 0.23 - Remote Code Execution (exploitdb)

## Other vulnerabilities in Apache Superset

- [CVE-2023-27524](https://insights.sbomify.com/CVE-2023-27524/): Apache Superset Insecure Default Initialization of Resource (high 8.9, exploited in the wild)
- [CVE-2022-27479](https://insights.sbomify.com/CVE-2022-27479/): SQL injection vulnerability in chart data API (critical 9.8)
- [CVE-2023-49657](https://insights.sbomify.com/CVE-2023-49657/): Apache Superset: Stored XSS in Dashboard Title and Chart Title (critical 9.6)
- [CVE-2022-43719](https://insights.sbomify.com/CVE-2022-43719/): Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API (high 8.8)
- [CVE-2021-41971](https://insights.sbomify.com/CVE-2021-41971/): Possible SQL Injection when template processing is enabled (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-8021 and fix it if it is affected.

What it is: CVE-2018-8021 is a critical unsafe deserialization vulnerability in Apache Superset, published on 7 Nov 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-8021 in the wild and no public exploit code.

Affected packages and fixed versions:
- superset (PyPI): affected all versions; fixed in 0.23
- superset (PyPI): affected all versions; fixed in 0.23
- superset (PyPI): affected all versions; fixed in 0.23.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-8021/ (Markdown: https://insights.sbomify.com/CVE-2018-8021/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-8021
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-8021
- OSV: https://osv.dev/vulnerability/CVE-2018-8021

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-8021/
Summaries are generated and may contain mistakes; the official description above is the record.
