CVE-2018-8022 Denial of service in Apache Traffic Server

High 7.5 Published Updated

A crafted TLS handshake causes Apache Traffic Server to crash, allowing attackers to disrupt service availability.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2018-8022?

CVE-2018-8022 is a high-severity denial of service vulnerability in Apache Traffic Server, published on 29 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A carefully crafted invalid TLS handshake can cause Apache Traffic Server (ATS) to segfault. This affects version 6.2.2. To resolve this issue users running 6.2.2 should upgrade to 6.2.3 or later versions.

Weakness: CWE-20

Which versions are affected by CVE-2018-8022?

It affects 1 product.

Products include Apache Traffic Server.

How do I fix CVE-2018-8022?

Upgrade to a fixed version.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2018-8022 being exploited?

There is no known exploitation of CVE-2018-8022 in the wild and no public exploit code.

All Apache Traffic Server vulnerabilities

Sources

Also known as DEBIAN-CVE-2018-8022, GHSA-gw79-rp24-2pgc.

Is CVE-2018-8022 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free