{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.sentry:sentry. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-8028 in the wild and no public exploit code.","fix":"Upgrade org.apache.sentry:sentry to 2.0.1 or later.","what":"CVE-2018-8028 is a high-severity missing authorization vulnerability in Apache Sentry, published on 23 Aug 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-8028 and fix it if it is affected.\n\nWhat it is: CVE-2018-8028 is a high-severity missing authorization vulnerability in Apache Sentry, published on 23 Aug 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-8028 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.sentry:sentry (Maven): affected all versions; fixed in 2.0.1\n- org.apache.sentry:sentry (Maven): affected all versions; fixed in 2.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-8028/ (Markdown: https://insights.sbomify.com/CVE-2018-8028/index.md)","id":"CVE-2018-8028","markdown":"https://insights.sbomify.com/CVE-2018-8028/index.md","name":"CVE-2018-8028","record":{"aliases":["GHSA-6xhj-p29v-82j8"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Sentry","requires_auth":"low_privilege","summary":"Authenticated users can bypass Apache Sentry authorization to read or delete partitioned data via ALTER TABLE commands.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"sentry","vendor":"apache"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"}],"description":"An authenticated user can execute ALTER TABLE EXCHANGE PARTITIONS without being authorized by Apache Sentry before 2.0.1. This can allow an attacker unauthorized access to the partitioned data of a Sentry protected table and can allow an attacker to remove data from a Sentry protected table.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Sentry may allow attacker to access/remove data from Sentry protected table","id":"CVE-2018-8028","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"missing_authorization","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"Privilege escalation vulnerability in Apache Hadoop","id":"CVE-2018-8029"},"packages":[{"ecosystem":"Maven","fixed":["2.0.1"],"introduced":["0"],"last_affected":[],"package":"org.apache.sentry:sentry","purl":null,"source":"GHSA-6xhj-p29v-82j8"},{"ecosystem":"Maven","fixed":["2.0.1"],"introduced":["0"],"last_affected":[],"package":"org.apache.sentry:sentry","purl":"pkg:maven/org.apache.sentry/sentry","source":"GHSA-6xhj-p29v-82j8"}],"prev":{"headline":"Apache is vulnerable to XXE in XSD validation processor","id":"CVE-2018-8027"},"products":["Apache Sentry"],"published":"2018-08-23","related":[{"cvss_score":8.8,"headline":"Code injection in n/a","id":"CVE-2016-0760","kev_date_added":null,"published":"2016-08-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["Apache Software Foundation"]},"summary":"Authenticated users can bypass Apache Sentry authorization to read or delete partitioned data via ALTER TABLE commands.","url":"https://insights.sbomify.com/CVE-2018-8028/"}