# CVE-2018-8028: Apache Sentry may allow attacker to access/remove data from Sentry protected table

> Authenticated users can bypass Apache Sentry authorization to read or delete partitioned data via ALTER TABLE commands.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Aug 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-6xhj-p29v-82j8

## What is CVE-2018-8028?

CVE-2018-8028 is a high-severity missing authorization vulnerability in Apache Sentry, published on 23 Aug 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An authenticated user can execute ALTER TABLE EXCHANGE PARTITIONS without being authorized by Apache Sentry before 2.0.1. This can allow an attacker unauthorized access to the partitioned data of a Sentry protected table and can allow an attacker to remove data from a Sentry protected table.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2018-8028?

2 open source packages ship an affected version, including org.apache.sentry:sentry. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.sentry:sentry` | Maven | All versions | 2.0.1 |
| `org.apache.sentry:sentry` | Maven | All versions | 2.0.1 |

Products: Apache Sentry.

## How do I fix CVE-2018-8028?

Upgrade org.apache.sentry:sentry to 2.0.1 or later.

## Is CVE-2018-8028 being exploited?

There is no known exploitation of CVE-2018-8028 in the wild and no public exploit code.

## Other vulnerabilities in Apache Sentry

- [CVE-2016-0760](https://insights.sbomify.com/CVE-2016-0760/): Code injection in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-8028 and fix it if it is affected.

What it is: CVE-2018-8028 is a high-severity missing authorization vulnerability in Apache Sentry, published on 23 Aug 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-8028 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.sentry:sentry (Maven): affected all versions; fixed in 2.0.1
- org.apache.sentry:sentry (Maven): affected all versions; fixed in 2.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-8028/ (Markdown: https://insights.sbomify.com/CVE-2018-8028/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-8028
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-8028
- OSV: https://osv.dev/vulnerability/CVE-2018-8028

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-8028/
Summaries are generated and may contain mistakes; the official description above is the record.
