# CVE-2018-8030: Denial of service vulnerability exists when .NET and .NET Core improperly process XML documents

> An attacker can crash the Apache Qpid Broker by publishing oversized messages via specific AMQP protocols, causing a denial of service.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jun 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-7xr3-rgwh-pw22

## What is CVE-2018-8030?

CVE-2018-8030 is a high-severity denial of service vulnerability in Apache Qpid Broker-J, published on 19 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A Denial of Service vulnerability was found in Apache Qpid Broker-J versions 7.0.0-7.0.4 when AMQP protocols 0-8, 0-9 or 0-91 are used to publish messages with size greater than allowed maximum message size limit (100MB by default). The broker crashes due to the defect. AMQP protocols 0-10 and 1.0 are not affected.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2018-8030?

2 open source packages ship an affected version, including org.apache.qpid:apache-qpid-broker-j. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.qpid:apache-qpid-broker-j` | Maven | From 7.0.0 | 7.1.0 |
| `org.apache.qpid:apache-qpid-broker-j` | Maven | From 7.0.0 | 7.1.0 |

Products: Apache Qpid Broker-J.

## How do I fix CVE-2018-8030?

Upgrade org.apache.qpid:apache-qpid-broker-j to 7.1.0 or later.

## Is CVE-2018-8030 being exploited?

There is no known exploitation of CVE-2018-8030 in the wild and no public exploit code.

## Other vulnerabilities in Apache Qpid Broker-J

- [CVE-2026-92609](https://insights.sbomify.com/CVE-2026-92609/): Apache Qpid Broker-J: Missing HTTP-session renewal after successful authentication (critical 9.8)
- [CVE-2017-15702](https://insights.sbomify.com/CVE-2017-15702/): Apache Qpid Broker vulnerable to authentication port spoofing (critical 9.8)
- [CVE-2016-4432](https://insights.sbomify.com/CVE-2016-4432/): AMQP 0-8, 0-9, 0-91, and 0-10 connection handling in Apache Qpid Java before 6.0.3 might allow remote attackers to bypass authentication (critical 9.1)
- [CVE-2026-92550](https://insights.sbomify.com/CVE-2026-92550/): Denial of service in Apache Qpid Broker-J (high 7.5)
- [CVE-2026-92560](https://insights.sbomify.com/CVE-2026-92560/): Denial of service in Apache Qpid Broker-J (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-8030 and fix it if it is affected.

What it is: CVE-2018-8030 is a high-severity denial of service vulnerability in Apache Qpid Broker-J, published on 19 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-8030 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.qpid:apache-qpid-broker-j (Maven): affected from 7.0.0; fixed in 7.1.0
- org.apache.qpid:apache-qpid-broker-j (Maven): affected from 7.0.0; fixed in 7.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-8030/ (Markdown: https://insights.sbomify.com/CVE-2018-8030/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-8030
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-8030
- OSV: https://osv.dev/vulnerability/CVE-2018-8030

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-8030/
Summaries are generated and may contain mistakes; the official description above is the record.
