CVE-2018-8035 Cross-site Scripting in Apache UIMA

Medium 6.1 Published Updated

Insufficient input filtering in Apache UIMA DUCC allows attackers to execute arbitrary JavaScript in users' browsers.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2018-8035?

CVE-2018-8035 is a medium-severity cross-site scripting vulnerability in Apache UIMA DUCC, published on 1 May 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

This vulnerability relates to the user's browser processing of DUCC webpage input data.The javascript comprising Apache UIMA DUCC (<= 2.2.2) which runs in the user's browser does not sufficiently filter user supplied inputs, which may result in unintended execution of user supplied javascript code.

Weakness: CWE-79

Which versions are affected by CVE-2018-8035?

2 open source packages ship an affected version, including org.apache.uima:uima-ducc-web. It affects 1 product.

PackageAffectedFixed in
org.apache.uima:uima-ducc-web MavenAll versions3.0.0
org.apache.uima:uima-ducc-web MavenAll versions3.0.0

Products include Apache Uimaducc.

How do I fix CVE-2018-8035?

Upgrade org.apache.uima:uima-ducc-web to 3.0.0 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2018-8035 being exploited?

There is no known exploitation of CVE-2018-8035 in the wild and no public exploit code.

Sources

Also known as GHSA-vm59-329q-p468, UBUNTU-CVE-2018-8035.

Is CVE-2018-8035 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free