# CVE-2018-8035: Cross-site Scripting in Apache UIMA

> Insufficient input filtering in Apache UIMA DUCC allows attackers to execute arbitrary JavaScript in users' browsers.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 May 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-vm59-329q-p468, UBUNTU-CVE-2018-8035

## What is CVE-2018-8035?

CVE-2018-8035 is a medium-severity cross-site scripting vulnerability in Apache UIMA DUCC, published on 1 May 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

This vulnerability relates to the user's browser processing of DUCC webpage input data.The javascript comprising Apache UIMA DUCC (<= 2.2.2) which runs in the user's browser does not sufficiently filter user supplied inputs, which may result in unintended execution of user supplied javascript code.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-8035?

2 open source packages ship an affected version, including org.apache.uima:uima-ducc-web. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.uima:uima-ducc-web` | Maven | All versions | 3.0.0 |
| `org.apache.uima:uima-ducc-web` | Maven | All versions | 3.0.0 |

Products: Apache Uimaducc.

## How do I fix CVE-2018-8035?

Upgrade org.apache.uima:uima-ducc-web to 3.0.0 or later.

## Is CVE-2018-8035 being exploited?

There is no known exploitation of CVE-2018-8035 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-8035 and fix it if it is affected.

What it is: CVE-2018-8035 is a medium-severity cross-site scripting vulnerability in Apache UIMA DUCC, published on 1 May 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-8035 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.uima:uima-ducc-web (Maven): affected all versions; fixed in 3.0.0
- org.apache.uima:uima-ducc-web (Maven): affected all versions; fixed in 3.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-8035/ (Markdown: https://insights.sbomify.com/CVE-2018-8035/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-8035
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-8035
- OSV: https://osv.dev/vulnerability/CVE-2018-8035

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-8035/
Summaries are generated and may contain mistakes; the official description above is the record.
