# CVE-2018-8038: High severity vulnerability that affects org.apache.cxf.fediz:fediz-jetty8, org.apache.cxf.fediz:fediz-jetty9, org.apache.cxf.fediz:fediz-spring, org.apache.cxf.fediz:fediz-spring2, and org.apache.cxf.fediz:fediz-spring3

> Attackers can exploit insufficient DTD disabling in Apache CXF Fediz to perform XML External Entity attacks, potentially reading sensitive data or causing denial of service.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Jul 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-w3gh-g32m-cvhr

## What is CVE-2018-8038?

CVE-2018-8038 is a high-severity vulnerability in Apache CXF Fediz, published on 5 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of Apache CXF Fediz prior to 1.4.4 do not fully disable Document Type Declarations (DTDs) when either parsing the Identity Provider response in the application plugins, or in the Identity Provider itself when parsing certain XML-based parameters.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2018-8038?

10 open source packages ship an affected version, including org.apache.cxf.fediz:fediz-jetty8, org.apache.cxf.fediz:fediz-jetty9 and org.apache.cxf.fediz:fediz-spring. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.cxf.fediz:fediz-jetty8` | Maven | All versions | 1.4.4 |
| `org.apache.cxf.fediz:fediz-jetty8` | Maven | All versions | 1.4.4 |
| `org.apache.cxf.fediz:fediz-jetty9` | Maven | All versions | 1.4.4 |
| `org.apache.cxf.fediz:fediz-jetty9` | Maven | All versions | 1.4.4 |
| `org.apache.cxf.fediz:fediz-spring` | Maven | All versions | 1.4.4 |
| `org.apache.cxf.fediz:fediz-spring` | Maven | All versions | 1.4.4 |
| `org.apache.cxf.fediz:fediz-spring2` | Maven | All versions | 1.4.4 |
| `org.apache.cxf.fediz:fediz-spring2` | Maven | All versions | 1.4.4 |
| `org.apache.cxf.fediz:fediz-spring3` | Maven | All versions | 1.4.4 |
| `org.apache.cxf.fediz:fediz-spring3` | Maven | All versions | 1.4.4 |

Products: Apache Cxf Fediz.

## How do I fix CVE-2018-8038?

Upgrade org.apache.cxf.fediz:fediz-jetty8 to 1.4.4 or later.

## Is CVE-2018-8038 being exploited?

There is no known exploitation of CVE-2018-8038 in the wild and no public exploit code.

Public exploit code:

- https://github.com/tafamace/CVE-2018-8038 (github_poc): https://github.com/tafamace/CVE-2018-8038

## Other vulnerabilities in Apache CXF Fediz

- [CVE-2016-4464](https://insights.sbomify.com/CVE-2016-4464/): High severity vulnerability that affects org.apache.cxf.fediz:fediz-spring and org.apache.cxf.fediz:fediz-spring2 (critical 9.8)
- [CVE-2017-12631](https://insights.sbomify.com/CVE-2017-12631/): Moderate severity vulnerability that affects org.apache.cxf.fediz:fediz-spring, org.apache.cxf.fediz:fediz-spring2, and org.apache.cxf.fediz:fediz-spring3 (high 8.8)
- [CVE-2017-7661](https://insights.sbomify.com/CVE-2017-7661/): Moderate severity vulnerability that affects org.apache.cxf.fediz:fediz-jetty8, org.apache.cxf.fediz:fediz-jetty9, and org.apache.cxf.fediz:fediz-spring2 (high 8.8)
- [CVE-2017-7662](https://insights.sbomify.com/CVE-2017-7662/): Cross-Site Request Forgery in Apache CXF Fediz (high 8.8)
- [CVE-2015-5175](https://insights.sbomify.com/CVE-2015-5175/): Apache CXF Fediz application plugins are vulnerable to Denial of Service (DoS) attacks (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-8038 and fix it if it is affected.

What it is: CVE-2018-8038 is a high-severity vulnerability in Apache CXF Fediz, published on 5 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-8038 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.cxf.fediz:fediz-jetty8 (Maven): affected all versions; fixed in 1.4.4
- org.apache.cxf.fediz:fediz-jetty8 (Maven): affected all versions; fixed in 1.4.4
- org.apache.cxf.fediz:fediz-jetty9 (Maven): affected all versions; fixed in 1.4.4
- org.apache.cxf.fediz:fediz-jetty9 (Maven): affected all versions; fixed in 1.4.4
- org.apache.cxf.fediz:fediz-spring (Maven): affected all versions; fixed in 1.4.4
- org.apache.cxf.fediz:fediz-spring (Maven): affected all versions; fixed in 1.4.4
- org.apache.cxf.fediz:fediz-spring2 (Maven): affected all versions; fixed in 1.4.4
- org.apache.cxf.fediz:fediz-spring2 (Maven): affected all versions; fixed in 1.4.4
- org.apache.cxf.fediz:fediz-spring3 (Maven): affected all versions; fixed in 1.4.4
- org.apache.cxf.fediz:fediz-spring3 (Maven): affected all versions; fixed in 1.4.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-8038/ (Markdown: https://insights.sbomify.com/CVE-2018-8038/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-8038
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-8038
- OSV: https://osv.dev/vulnerability/CVE-2018-8038

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-8038/
Summaries are generated and may contain mistakes; the official description above is the record.
