CVE-2018-8040 Information disclosure in Apache Traffic Server

Medium 5.3 Published Updated

Attackers can access cookie headers in ESI-rendered pages when the plugin is configured to restrict access, potentially exposing sensitive session data.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2018-8040?

CVE-2018-8040 is a medium-severity vulnerability in Apache Traffic Server, published on 29 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Pages that are rendered using the ESI plugin can have access to the cookie header when the plugin is configured not to allow access. This affects Apache Traffic Server (ATS) versions 6.0.0 to 6.2.2 and 7.0.0 to 7.1.3. To resolve this issue users running 6.x should upgrade to 6.2.3 or later versions and 7.x users should upgrade to 7.1.4 or later versions.

Weakness: CWE-668

Which versions are affected by CVE-2018-8040?

It affects 2 products.

Products include Apache Traffic Server, Debian Debian Linux.

How do I fix CVE-2018-8040?

Upgrade to a fixed version.

Is CVE-2018-8040 being exploited?

There is no known exploitation of CVE-2018-8040 in the wild and no public exploit code.

All Apache Traffic Server vulnerabilities

Sources

Also known as DEBIAN-CVE-2018-8040, GHSA-g5v3-3xfp-hgx6, UBUNTU-CVE-2018-8040.

Is CVE-2018-8040 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free