# CVE-2018-8041: Apache Camel's Mail is vulnerable to path traversal

> Attackers can exploit path traversal in Apache Camel Mail component to read or modify arbitrary files on the server.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Sep 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-jv74-f9pj-xp3f

## What is CVE-2018-8041?

CVE-2018-8041 is a medium-severity path traversal vulnerability in Apache Camel, published on 17 Sep 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Camel's Mail 2.20.0 through 2.20.3, 2.21.0 through 2.21.1 and 2.22.0 is vulnerable to path traversal.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2018-8041?

6 open source packages ship an affected version, including org.apache.camel:camel-mail. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.camel:camel-mail` | Maven | From 2.20.0 | 2.20.4 |
| `org.apache.camel:camel-mail` | Maven | From 2.20.0 | 2.20.4 |
| `org.apache.camel:camel-mail` | Maven | From 2.21.0 | 2.21.2 |
| `org.apache.camel:camel-mail` | Maven | From 2.21.0 | 2.21.2 |
| `org.apache.camel:camel-mail` | Maven | From 2.22.0 | 2.22.1 |
| `org.apache.camel:camel-mail` | Maven | From 2.22.0 | 2.22.1 |

Products: Apache Camel.

## How do I fix CVE-2018-8041?

Upgrade org.apache.camel:camel-mail to a fixed version for your release line: 2.20.4, 2.21.2 or 2.22.1.

## Is CVE-2018-8041 being exploited?

There is no known exploitation of CVE-2018-8041 in the wild and no public exploit code.

Public exploit code:

- https://github.com/shoucheng3/apache__camel_CVE-2018-8041_2-20-3 (github_poc): https://github.com/shoucheng3/apache__camel_CVE-2018-8041_2-20-3

## Other vulnerabilities in Apache Camel

- [CVE-2026-33453](https://insights.sbomify.com/CVE-2026-33453/): Apache camel-coap allows header injection that can lead to remote code execution (critical 10.0)
- [CVE-2026-40453](https://insights.sbomify.com/CVE-2026-40453/): Apache Camel has an incomplete fix for CVE-2025-27636 (critical 9.9)
- [CVE-2026-80351](https://insights.sbomify.com/CVE-2026-80351/): Apache Camel K: Camel K Tenant repositories reach Maven execution inside operator pod (critical 9.8)
- [CVE-2026-80352](https://insights.sbomify.com/CVE-2026-80352/): Apache Camel K: Camel K Master trait serviceAccountName YAML injection lets CR author apply arbitrary objects (critical 9.8)
- [CVE-2026-71300](https://insights.sbomify.com/CVE-2026-71300/): Apache Camel: Camel-Atmosphere-Websocket: WebSocket dispatch header injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-8041 and fix it if it is affected.

What it is: CVE-2018-8041 is a medium-severity path traversal vulnerability in Apache Camel, published on 17 Sep 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-8041 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.camel:camel-mail (Maven): affected from 2.20.0; fixed in 2.20.4
- org.apache.camel:camel-mail (Maven): affected from 2.20.0; fixed in 2.20.4
- org.apache.camel:camel-mail (Maven): affected from 2.21.0; fixed in 2.21.2
- org.apache.camel:camel-mail (Maven): affected from 2.21.0; fixed in 2.21.2
- org.apache.camel:camel-mail (Maven): affected from 2.22.0; fixed in 2.22.1
- org.apache.camel:camel-mail (Maven): affected from 2.22.0; fixed in 2.22.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-8041/ (Markdown: https://insights.sbomify.com/CVE-2018-8041/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-8041
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-8041
- OSV: https://osv.dev/vulnerability/CVE-2018-8041

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-8041/
Summaries are generated and may contain mistakes; the official description above is the record.
