# CVE-2018-8048: Cross-site Scripting in loofah

> Attackers can inject malicious scripts into sanitized HTML output via non-whitelisted attributes, potentially leading to cross-site scripting attacks.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Mar 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-8048, DSA-4171-1, GHSA-x7rv-cr6v-4vm4, SUSE-SU-2019:2209-1

## What is CVE-2018-8048?

CVE-2018-8048 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 27 Mar 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In the Loofah gem through 2.2.0 for Ruby, non-whitelisted HTML attributes may occur in sanitized output by republishing a crafted HTML fragment.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-8048?

4 open source packages ship an affected version, including loofah and nokogiri. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `loofah` | RubyGems | All versions | 2.2.1 |
| `loofah` | RubyGems | All versions | 2.2.1 |
| `nokogiri` | RubyGems | All versions | 1.8.3 |
| `nokogiri` | RubyGems | All versions | 1.8.3 |
| `rubygem-loofah` | SUSE:Enterprise Storage 4 | All versions | 2.0.2-3.8.1 |
| `rubygem-loofah` | SUSE:OpenStack Cloud 7 | All versions | 2.0.2-3.8.1 |
| `rubygem-loofah` | SUSE:OpenStack Cloud Crowbar 8 | All versions | 2.0.2-3.8.1 |
| `rubygem-loofah` | SUSE:OpenStack Cloud Crowbar 9 | All versions | 2.0.2-3.8.1 |

Products: Debian Debian Linux, Loofah Project Loofah.

## How do I fix CVE-2018-8048?

Upgrade loofah to 2.2.1 or later.

## Is CVE-2018-8048 being exploited?

There is no known exploitation of CVE-2018-8048 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-8048 and fix it if it is affected.

What it is: CVE-2018-8048 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 27 Mar 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-8048 in the wild and no public exploit code.

Affected packages and fixed versions:
- loofah (RubyGems): affected all versions; fixed in 2.2.1
- loofah (RubyGems): affected all versions; fixed in 2.2.1
- nokogiri (RubyGems): affected all versions; fixed in 1.8.3
- nokogiri (RubyGems): affected all versions; fixed in 1.8.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-8048/ (Markdown: https://insights.sbomify.com/CVE-2018-8048/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-8048
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-8048
- OSV: https://osv.dev/vulnerability/CVE-2018-8048

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-8048/
Summaries are generated and may contain mistakes; the official description above is the record.
