# CVE-2018-8071: XSS vulnerability in theme config file in Mautic

> Attackers can inject malicious scripts via theme config files in Mautic, potentially leading to session hijacking or code execution.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Apr 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-5w74-jx7m-x6hv

## What is CVE-2018-8071?

CVE-2018-8071 is a medium-severity cross-site scripting vulnerability in n/a, published on 18 Apr 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Mautic before v2.13.0 has stored XSS via a theme config file.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-8071?

2 open source packages ship an affected version, including mautic/core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mautic/core` | Packagist | All versions | 2.13.0 |
| `mautic/core` | Packagist | All versions | 2.13.0 |

Products: Mautic Mautic.

## How do I fix CVE-2018-8071?

Upgrade mautic/core to 2.13.0 or later.

## Is CVE-2018-8071 being exploited?

There is no known exploitation of CVE-2018-8071 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-8092](https://insights.sbomify.com/CVE-2018-8092/): CSV Injection vulnerability with exported contact lists in Mautic (critical 9.8)
- [CVE-2020-35129](https://insights.sbomify.com/CVE-2020-35129/): Mautic stored Cross-site Scripting (XSS) (critical 9.0)
- [CVE-2018-10189](https://insights.sbomify.com/CVE-2018-10189/): Mautic Sessions could be hijacked due to tracking contacts by an auto-incremented ID (high 7.5)
- [CVE-2017-1000046](https://insights.sbomify.com/CVE-2017-1000046/): Sensitive Cookie Without HttpOnly and Secure Flag (high 7.5)
- [CVE-2017-1000506](https://insights.sbomify.com/CVE-2017-1000506/): Mautic Cross Site Scripting (XSS) vulnerability (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-8071 and fix it if it is affected.

What it is: CVE-2018-8071 is a medium-severity cross-site scripting vulnerability in n/a, published on 18 Apr 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-8071 in the wild and no public exploit code.

Affected packages and fixed versions:
- mautic/core (Packagist): affected all versions; fixed in 2.13.0
- mautic/core (Packagist): affected all versions; fixed in 2.13.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-8071/ (Markdown: https://insights.sbomify.com/CVE-2018-8071/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-8071
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-8071
- OSV: https://osv.dev/vulnerability/CVE-2018-8071

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-8071/
Summaries are generated and may contain mistakes; the official description above is the record.
