# CVE-2018-8074: Yii Framework Code Injection

> Attackers can inject unintended search conditions in Yii applications using the Elasticsearch extension, potentially leading to code execution.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Mar 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-m2p5-fwp2-qcw2

## What is CVE-2018-8074?

CVE-2018-8074 is a high-severity code injection vulnerability in n/a, published on 21 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Yii 2.x before 2.0.15 allows remote attackers to inject unintended search conditions via a variant of the CVE-2018-7269 attack in conjunction with the Elasticsearch extension.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2018-8074?

4 open source packages ship an affected version, including yiisoft/yii2-dev and yiisoft/yii2-elasticsearch. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yiisoft/yii2-dev` | Packagist | From 2.0.0 | 2.0.15 |
| `yiisoft/yii2-dev` | Packagist | From 2.0.0 | 2.0.15 |
| `yiisoft/yii2-elasticsearch` | Packagist | All versions | 2.0.5 |
| `yiisoft/yii2-elasticsearch` | Packagist | All versions | 2.0.5 |

Products: Yiiframework Yii.

## How do I fix CVE-2018-8074?

Upgrade yiisoft/yii2-dev to 2.0.15 or later.

## Is CVE-2018-8074 being exploited?

There is no known exploitation of CVE-2018-8074 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2024-58136](https://insights.sbomify.com/CVE-2024-58136/): Yiiframework Yii Improper Protection of Alternate Path (critical 9.0, exploited in the wild)
- [CVE-2015-5467](https://insights.sbomify.com/CVE-2015-5467/): Yii2 allows attackers to execute any local .php file via a relative path in the view parameter (critical 9.8)
- [CVE-2023-26750](https://insights.sbomify.com/CVE-2023-26750/): SQL injection in n/a (critical 9.8)
- [CVE-2018-7269](https://insights.sbomify.com/CVE-2018-7269/): Yii SQL injection vulnerability (critical 9.8)
- [CVE-2018-8073](https://insights.sbomify.com/CVE-2018-8073/): yii2-redis Potential Remote code execution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-8074 and fix it if it is affected.

What it is: CVE-2018-8074 is a high-severity code injection vulnerability in n/a, published on 21 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-8074 in the wild and no public exploit code.

Affected packages and fixed versions:
- yiisoft/yii2-dev (Packagist): affected from 2.0.0; fixed in 2.0.15
- yiisoft/yii2-dev (Packagist): affected from 2.0.0; fixed in 2.0.15
- yiisoft/yii2-elasticsearch (Packagist): affected all versions; fixed in 2.0.5
- yiisoft/yii2-elasticsearch (Packagist): affected all versions; fixed in 2.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-8074/ (Markdown: https://insights.sbomify.com/CVE-2018-8074/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-8074
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-8074
- OSV: https://osv.dev/vulnerability/CVE-2018-8074

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-8074/
Summaries are generated and may contain mistakes; the official description above is the record.
