{"answers":{"affected":"3 open source packages ship an affected version, including eve. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-8097 in the wild and no public exploit code.","fix":"Upgrade eve to 0.7.5 or later.","what":"CVE-2018-8097 is a critical code injection vulnerability in n/a, published on 14 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-8097 and fix it if it is affected.\n\nWhat it is: CVE-2018-8097 is a critical code injection vulnerability in n/a, published on 14 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-8097 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- eve (PyPI): affected all versions; fixed in 0.7.5\n- eve (PyPI): affected all versions; fixed in 0.7.5\n- eve (PyPI): affected all versions; fixed in 0.7.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-8097/ (Markdown: https://insights.sbomify.com/CVE-2018-8097/index.md)","id":"CVE-2018-8097","markdown":"https://insights.sbomify.com/CVE-2018-8097/index.md","name":"CVE-2018-8097","record":{"aliases":["GHSA-8jxq-75rw-fhj9","PYSEC-2018-8"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python REST API framework","requires_auth":"none","summary":"Remote attackers can execute arbitrary code via the where parameter in the Eve Python framework.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"eve","vendor":"python-eve"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"io/mongo/parser.py in Eve (aka pyeve) before 0.7.5 allows remote attackers to execute arbitrary code via Code Injection in the where parameter.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":"2023-01-19","github_poc":2,"max_poc_stars":1,"metasploit":0,"nuclei":0,"refs":[{"date":"2023-01-19T13:31:12Z","kind":"github_poc","ref":"https://github.com/SilentVoid13/CVE-2018-8097","stars":1,"title":"CVE-2018-8097 PoC"},{"date":"2025-05-28T13:49:12Z","kind":"github_poc","ref":"https://github.com/StellarDriftLabs/CVE-2018-8097-PoC","stars":0,"title":"POC for CVE-2018-8097 This script exploits CVE-2018-8097 and can retrieve files and contents using a blind RCE method."}],"tier":"poc_unverified"},"has_fix":true,"headline":"Eve allows execution of arbitrary code","id":"CVE-2018-8097","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2018"},"n_packages":3,"n_references":2,"next":{"headline":"Integer overflow in n/a","id":"CVE-2018-8098"},"packages":[{"ecosystem":"PyPI","fixed":["0.7.5"],"introduced":["0"],"last_affected":[],"package":"eve","purl":null,"source":"GHSA-8jxq-75rw-fhj9"},{"ecosystem":"PyPI","fixed":["0.7.5"],"introduced":["0"],"last_affected":[],"package":"eve","purl":"pkg:pypi/eve","source":"GHSA-8jxq-75rw-fhj9"},{"ecosystem":"PyPI","fixed":["0.7.5"],"introduced":["0"],"last_affected":[],"package":"eve","purl":"pkg:pypi/eve","source":"PYSEC-2018-8"}],"prev":{"headline":"Auth bypass in n/a","id":"CVE-2018-8096"},"products":["n/a"],"published":"2018-03-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary code via the where parameter in the Eve Python framework.","url":"https://insights.sbomify.com/CVE-2018-8097/"}